View Issue Details

IDProjectCategoryView StatusLast Update
0001186bareos-core[All Projects] configuration guipublic2020-02-12 09:50
ReporterhostedpowerAssigned Toarogge 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionduplicate 
PlatformLinuxOSDebianOS Version9
Product Version19.2.5 
Fixed in Version 
Summary0001186: Hard to restore with bareos webui after upgrading to 19.2
DescriptionWhen we go to: https://backupmaster/restore/ , the page keeps loading forever to end up with an empty screen.

Afterwards we can restore by selecting the correct date of a specific server...

However this takes a really really long time since we have to wait for it to timeout first... :(

So all restores takes much more time as before.

The reason this happens it because the WebUI tries to select the OLDEST backup first instead of the newest. The oldest one often hasn't got all volumes anymore (so it cannot find a full backup).

It should select newest backup as it always did before :)

Steps To ReproduceUpgrade to 19.2.x (with always incremental backup scheme)
Trying to restore anything by browsing to the restore selection
Oldest backup is selected instead of newest, giving a lot of timeouts.
TagsNo tags attached.
bareos-master: impact
bareos-master: action
bareos-19.2: impact
bareos-19.2: action
bareos-18.2: impact
bareos-18.2: action
bareos-17.2: impact
bareos-17.2: action
bareos-16.2: impact
bareos-16.2: action
bareos-15.2: impact
bareos-15.2: action
bareos-14.2: impact
bareos-14.2: action
bareos-13.2: impact
bareos-13.2: action
bareos-12.4: impact
bareos-12.4: action

Relationships

duplicate of 0001178 closedarogge backup job selection in restore module is populated not properly 

Activities

hostedpower

hostedpower

2020-02-11 17:27

reporter   ~0003789

I'm sorry, I didn't see it existed already :(

Since the newer version isn't released yet, the nightly probably isn't a good idea.

Any way to get this fixed quickly or in what timeframe will the newer version be released? It's quite blocking for us atm :)
arogge

arogge

2020-02-11 17:30

developer   ~0003790

The new version has already been released, packages are building right now.
hostedpower

hostedpower

2020-02-11 21:06

reporter   ~0003791

Doesn't seem full resolved, the initial loading is still very slow, it tries to load something non existent it seems.

Additionally restoring is broken completely now it seems. (see https://bugs.bareos.org/view.php?id=1188)
hostedpower

hostedpower

2020-02-11 21:18

reporter   ~0003793

PS: I just found out that it's only in Internet explorer, chrome and edge work fine for restoring

However the issue of slow loading persists, initial loading of the https://bareosbackup/restore url is slow, once a client is selected after that, it's finally faster
arogge

arogge

2020-02-12 09:50

developer   ~0003796

The original issue this ticket was created for had been fixed already.
it would be nice if you could create another issue for the loading-problem according to our Bug Reporting Howto https://www.bareos.org/en/HOWTO/articles/how-to-create-a-bugreport.html

Thank you.

Issue History

Date Modified Username Field Change
2020-02-11 16:50 hostedpower New Issue
2020-02-11 17:16 arogge Relationship added duplicate of 0001178
2020-02-11 17:17 arogge Assigned To => arogge
2020-02-11 17:17 arogge Status new => resolved
2020-02-11 17:17 arogge Resolution open => duplicate
2020-02-11 17:17 arogge Status resolved => closed
2020-02-11 17:27 hostedpower Status closed => new
2020-02-11 17:27 hostedpower Resolution duplicate => reopened
2020-02-11 17:27 hostedpower Note Added: 0003789
2020-02-11 17:30 arogge Status new => closed
2020-02-11 17:30 arogge Note Added: 0003790
2020-02-11 21:06 hostedpower Status closed => new
2020-02-11 21:06 hostedpower Note Added: 0003791
2020-02-11 21:18 hostedpower Note Added: 0003793
2020-02-12 09:50 arogge Status new => resolved
2020-02-12 09:50 arogge Resolution reopened => duplicate
2020-02-12 09:50 arogge Note Added: 0003796
2020-02-12 09:50 arogge Status resolved => closed