View Issue Details

IDProjectCategoryView StatusLast Update
0001168bareos-core[All Projects] bconsolepublic2020-02-25 13:36
Reporterv1adikAssigned Toarogge 
PriorityhighSeveritycrashReproducibilityrandom
Status closedResolutionunable to reproduce 
PlatformLinuxOSCentOSOS Version6
Product Version18.2.5 
Fixed in Version 
Summary0001168: Crash
DescriptionCrashes once in a week, with absolutely different jobs in work, but same -Console- job in backtrace.
And what is JobLevel=U ?

Steps To ReproduceRandom jobs
Additional InformationBacktrace

Attempt to dump current JCRs. njcrs=4
threadid=0xd000007feb7f9fc7 JobId=0 JobStatus=R jcr=0x107b628 name=*JobMonitor*.2020-01-10_14.18.51_01
threadid=0xd000007feb7f9fc7 killable=0 JobId=0 JobStatus=R jcr=0x107b628 name=*JobMonitor*.2020-01-10_14.18.51_01
        UseCount=1
        JobType=I JobLevel=
        sched_time=10-Jan-2020 14:18 start_time=10-Jan-2020 14:18
        end_time=01-Jan-1970 03:00 wait_time=01-Jan-1970 03:00
        db=(nil) db_batch=(nil) batch_started=0
threadid=0x2900007feb73fff7 JobId=0 JobStatus=R jcr=0x7feb6c0008e8 name=*StatisticsCollector*.2020-01-10_14.18.51_02
threadid=0x2900007feb73fff7 killable=0 JobId=0 JobStatus=R jcr=0x7feb6c0008e8 name=*StatisticsCollector*.2020-01-10_14.18.51_02
        UseCount=1
        JobType=I JobLevel=
        sched_time=10-Jan-2020 14:18 start_time=10-Jan-2020 14:18
        end_time=01-Jan-1970 03:00 wait_time=01-Jan-1970 03:00
        db=0x7feb6c0021a8 db_batch=(nil) batch_started=0
BareosDb=0x7feb6c0021a8 db_name=bareos db_user=postgres connected=true
        cmd="SELECT MediaId,VolumeName,VolJobs,VolFiles,VolBlocks,VolBytes,VolMounts,VolErrors,VolWrites,MaxVolBytes,VolCapacityBytes,MediaType,VolStatus,PoolId,VolRetention,VolUseDuration,MaxVolJobs,MaxVolFiles,Recycle,Slot,FirstWritten,LastWritten,InChanger,EndFile,EndBlock,LabelType,LabelDate,StorageId,Enabled,LocationId,RecycleCount,InitialWrite,ScratchPoolId,RecyclePoolId,VolReadTime,VolWriteTime,ActionOnPurge,EncryptionKey,MinBlocksize,MaxBlocksize FROM Media WHERE VolumeName='web-netcast2-1193079-Incremental-20200114-04.21_12'" changes=10
        RWLOCK=0x7feb6c0021b0 w_active=0 w_wait=0
threadid=0x2100000000000000 JobId=1192824 JobStatus=R jcr=0x7feb5c010458 name=rhg_sputnikimages_vol4.2020-01-13_14.51.04_53
threadid=0x2100000000000000 killable=0 JobId=1192824 JobStatus=R jcr=0x7feb5c010458 name=rhg_sputnikimages_vol4.2020-01-13_14.51.04_53
        UseCount=2
        JobType=B JobLevel=F
        sched_time=13-Jan-2020 14:51 start_time=13-Jan-2020 14:51
        end_time=01-Jan-1970 03:00 wait_time=01-Jan-1970 03:00
        db=0x7feb6c0021a8 db_batch=0x7feb0000d9a8 batch_started=1
BareosDb=0x7feb6c0021a8 db_name=bareos db_user=postgres connected=true
        cmd="SELECT MediaId,VolumeName,VolJobs,VolFiles,VolBlocks,VolBytes,VolMounts,VolErrors,VolWrites,MaxVolBytes,VolCapacityBytes,MediaType,VolStatus,PoolId,VolRetention,VolUseDuration,MaxVolJobs,MaxVolFiles,Recycle,Slot,FirstWritten,LastWritten,InChanger,EndFile,EndBlock,LabelType,LabelDate,StorageId,Enabled,LocationId,RecycleCount,InitialWrite,ScratchPoolId,RecyclePoolId,VolReadTime,VolWriteTime,ActionOnPurge,EncryptionKey,MinBlocksize,MaxBlocksize FROM Media WHERE VolumeName='web-netcast2-1193079-Incremental-20200114-04.21_12'" changes=10
        RWLOCK=0x7feb6c0021b0 w_active=0 w_wait=0
threadid=0x0000007feb3ebfd7 JobId=0 JobStatus=R jcr=0x7feae0007598 name=-Console-.2020-01-13_17.33.15_52
threadid=0x0000007feb3ebfd7 killable=0 JobId=0 JobStatus=R jcr=0x7feae0007598 name=-Console-.2020-01-13_17.33.15_52
        UseCount=1
        JobType=U JobLevel=
        sched_time=13-Jan-2020 17:33 start_time=13-Jan-2020 17:33
        end_time=01-Jan-1970 03:00 wait_time=01-Jan-1970 03:00
        db=(nil) db_batch=(nil) batch_started=0
Tagsbconsole, director
bareos-master: impact
bareos-master: action
bareos-19.2: impact
bareos-19.2: action
bareos-18.2: impact
bareos-18.2: action
bareos-17.2: impact
bareos-17.2: action
bareos-16.2: impact
bareos-16.2: action
bareos-15.2: impact
bareos-15.2: action
bareos-14.2: impact
bareos-14.2: action
bareos-13.2: impact
bareos-13.2: action
bareos-12.4: impact
bareos-12.4: action

Activities

arogge

arogge

2020-01-17 17:14

developer   ~0003719

Can you reproduce this with the latest version?
Do you have statistics collection enabled? Maybe that's what crashes your director (it is known to sometimes cause issues).

What you attached is a thread dump, please make sure you generate a meaningful backtrace (see https://docs.bareos.org/Appendix/Debugging.html#traceback) and attach that one.
arogge

arogge

2020-02-25 13:36

developer   ~0003853

Closing due to no feedback from reporter. Please reopen if you have additional info.

Issue History

Date Modified Username Field Change
2020-01-14 16:04 v1adik New Issue
2020-01-14 16:04 v1adik Tag Attached: bconsole
2020-01-15 07:08 v1adik Tag Attached: director
2020-01-17 17:14 arogge Status new => feedback
2020-01-17 17:14 arogge Note Added: 0003719
2020-02-25 13:36 arogge Assigned To => arogge
2020-02-25 13:36 arogge Status feedback => closed
2020-02-25 13:36 arogge Resolution open => unable to reproduce
2020-02-25 13:36 arogge Note Added: 0003853