View Issue Details

IDProjectCategoryView StatusLast Update
0001097bareos-corefile daemonpublic2019-07-04 15:56
Reportergnif Assigned Toarogge  
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionduplicate 
PlatformLinuxOSDebianOS Version9
Product Version18.2.6 
Summary0001097: Systemd expexts bareos-fd to be on port 9102
DescriptionOn some systems I need to run Bareos on a different port as 9102 conflicts with the sphinx search indexer, however the system.d unit specifically looks for a pid file with the bareos-fd port of 9102 causing systemd to think that startup of the bareos-fd has failed.

While this can be worked around, when any updates to the system are performed that require a restart of bareos, the failure to restart the package causes the apt package manager to halt any further work.
Steps To Reproduce1) Install bareos-filedaemon on Debian 9
2) Set the port in mysqlf.conf to anything other then 9102
3) Try to restart the service via `systemctl restart bareos-fd`
TagsNo tags attached.
bareos-master: impact
bareos-master: action
bareos-19.2: impact
bareos-19.2: action
bareos-18.2: impact
bareos-18.2: action
bareos-17.2: impact
bareos-17.2: action
bareos-16.2: impact
bareos-16.2: action
bareos-15.2: impact
bareos-15.2: action
bareos-14.2: impact
bareos-14.2: action
bareos-13.2: impact
bareos-13.2: action
bareos-12.4: impact
bareos-12.4: action

Relationships

duplicate of 0000928 confirmed using non-default port conflicts with systemd unit (and init script) PIDFile 

Activities

arogge

arogge

2019-07-03 09:32

developer   ~0003407

We know that this is an issue and it is already on our to-do list.
However, there's no easy fix from our side.

The systemd unit needs the literal pid-file, but bareos uses its port number in the pid-file's name.
The fix is to use Type=notify in systemd, but this needs some work in the daemons.

Issue History

Date Modified Username Field Change
2019-07-03 01:07 gnif New Issue
2019-07-03 09:32 arogge Assigned To => arogge
2019-07-03 09:32 arogge Status new => confirmed
2019-07-03 09:32 arogge Note Added: 0003407
2019-07-04 15:56 arogge Relationship added duplicate of 0000928
2019-07-04 15:56 arogge Status confirmed => closed
2019-07-04 15:56 arogge Resolution open => duplicate