View Issue Details

IDProjectCategoryView StatusLast Update
0001058bareos-core[All Projects] Generalpublic2019-10-17 15:22
ReportertuxmasterAssigned Toarogge 
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
PlatformLinuxOSRHELOS Version7
Product Version18.2.5 
Fixed in Version 
Summary0001058: 18.2.6 build error while cmake don't build the correct dependency's
DescriptionIt looks like, cmake produce an make file in which ndmp_tape.cc try to build before rpcgen was running for all files.
So the build will fails with:
[ 28%] Generating ndmp9.h, ndmp9_xdr.c
cd /builddir/build/BUILD/bareos-Release-18.2.6/core/src/ndmp && /usr/bin/rpcgen -CM /builddir/build/BUILD/bareos-Release-18.2.6/cor
e/src/ndmp/ndmp9.x
BUILDSTDERR: In file included from /builddir/build/BUILD/bareos-Release-18.2.6/core/src/ndmp/ndmlib.h:43:0,
BUILDSTDERR: from /builddir/build/BUILD/bareos-Release-18.2.6/core/src/ndmp/ndmagents.h:100,
BUILDSTDERR: from /builddir/build/BUILD/bareos-Release-18.2.6/core/src/stored/ndmp_tape.cc:45:
BUILDSTDERR: /builddir/build/BUILD/bareos-Release-18.2.6/core/src/ndmp/ndmprotocol.h:102:19: fatal error: ndmp0.h: No such file or
directory
BUILDSTDERR: #include "ndmp0.h"
BUILDSTDERR: ^
BUILDSTDERR: compilation terminated.
[ 29%] Generating ndmp0.h, ndmp0_xdr.c
cd /builddir/build/BUILD/bareos-Release-18.2.6/core/src/ndmp && /usr/bin/rpcgen -CM /builddir/build/BUILD/bareos-Release-18.2.6/core/src/ndmp/ndmp0.x
Additional InformationSee the build.log for the complete build.
TagsNo tags attached.
bareos-master: impact
bareos-master: action
bareos-19.2: impact
bareos-19.2: action
bareos-18.2: impact
bareos-18.2: action
bareos-17.2: impact
bareos-17.2: action
bareos-16.2: impact
bareos-16.2: action
bareos-15.2: impact
bareos-15.2: action
bareos-14.2: impact
bareos-14.2: action
bareos-13.2: impact
bareos-13.2: action
bareos-12.4: impact
bareos-12.4: action

Activities

tuxmaster

tuxmaster

2019-02-16 11:58

reporter  

build.log (226,170 bytes)
tuxmaster

tuxmaster

2019-03-31 13:59

reporter   ~0003307

Work around before the build:
for X in 0 2 3 4 9;do
rpcgen -CM ../core/src/ndmp/ndmp${X}.x
done
arogge

arogge

2019-07-10 17:39

developer   ~0003434

This has never happened to me.
What version of cmake are you using?
What is your cmake and make commandline?

In short: how can I reproduce this?
tuxmaster

tuxmaster

2019-07-13 10:36

reporter   ~0003458

cmake version 3.13.5 will used.
To reproduce it, simple use an fedora/redhat or centos system and try to build it using the default way on this platforms.
1. call rpmbuild -bs to create the srpm file
2. build the package via mock -r centos-7-x86_64 PATH_TO_SRPM
Then the build fails, because the files are not generated.

And to build it with my fix:
 mock -r centos-7-x86_64 PATH_TO_SRPM

Because the ticket system here is limit to 2MB I have uploaded all needed files to my nextcloud instance:
https://speicher.terrortux.de/s/tA5k5ZdMdjtZdbX
arogge

arogge

2019-07-19 15:24

developer   ~0003505

I build on CentOS 7 all the time using cmake 3.13.3.
So you must be hitting some kind of cornercase.
I have however, never tried building with "make -j2", just "make", "make -j" and "make -j8".

I'll have to look into that. Can you reliably reproduce this? Because I cannot...
tuxmaster

tuxmaster

2019-07-19 18:07

reporter  

log.tar.xz (37,972 bytes)
tuxmaster

tuxmaster

2019-07-19 18:07

reporter   ~0003506

Yes I can reproduce it on every build. And it play no role how many parallel build are used.
Also running make -j1 will fail.
I have attached all log files, that will crated during the build.
arogge

arogge

2019-07-22 13:17

developer   ~0003519

we'll see what we can do to fix this.
arogge

arogge

2019-10-02 13:22

developer   ~0003590

Fix committed to bareos master branch with changesetid 11842.
arogge

arogge

2019-10-17 15:22

developer   ~0003605

Fix committed to bareos bareos-18.2 branch with changesetid 11952.

Related Changesets

bareos: master 119631bf

2019-10-01 11:34:05

arogge

Ported: N/A

Details Diff
core: fix rpcgen ordering

Fixes 0001058: 18.2.6 build error while cmake don't build the correct dependency's

previously rpcgen was called using add_custom_command in PRE_BUILD
mode. That mode doesn't work reliably.
We now generate files that the bareosndmp target can depend on. This
should get the build ordering right every time.
Affected Issues
0001058
mod - core/src/ndmp/CMakeLists.txt Diff File

bareos: bareos-18.2 ea9bc969

2019-10-01 11:34:05

arogge

Ported: N/A

Details Diff
core: fix rpcgen ordering

Fixes 0001058: 18.2.6 build error while cmake don't build the correct dependency's

previously rpcgen was called using add_custom_command in PRE_BUILD
mode. That mode doesn't work reliably.
We now generate files that the bareosndmp target can depend on. This
should get the build ordering right every time.

(cherry picked from commit 119631bfe3dfd98ccdbc1260e4077220402ddec0)
Affected Issues
0001058
mod - core/src/ndmp/CMakeLists.txt Diff File

Issue History

Date Modified Username Field Change
2019-02-16 11:58 tuxmaster New Issue
2019-02-16 11:58 tuxmaster File Added: build.log
2019-03-31 13:59 tuxmaster Note Added: 0003307
2019-07-10 17:39 arogge Status new => feedback
2019-07-10 17:39 arogge Note Added: 0003434
2019-07-13 10:36 tuxmaster Note Added: 0003458
2019-07-13 10:36 tuxmaster Status feedback => new
2019-07-19 15:24 arogge Status new => feedback
2019-07-19 15:24 arogge Note Added: 0003505
2019-07-19 18:07 tuxmaster File Added: log.tar.xz
2019-07-19 18:07 tuxmaster Note Added: 0003506
2019-07-19 18:07 tuxmaster Status feedback => new
2019-07-22 13:17 arogge Status new => acknowledged
2019-07-22 13:17 arogge Note Added: 0003519
2019-10-01 13:57 arogge Assigned To => arogge
2019-10-01 13:57 arogge Status acknowledged => assigned
2019-10-02 13:22 arogge Changeset attached => bareos master 119631bf
2019-10-02 13:22 arogge Note Added: 0003590
2019-10-02 13:22 arogge Status assigned => resolved
2019-10-02 13:22 arogge Resolution open => fixed
2019-10-17 15:22 arogge Changeset attached => bareos bareos-18.2 ea9bc969
2019-10-17 15:22 arogge Note Added: 0003605