View Issue Details

IDProjectCategoryView StatusLast Update
0001047bareos-core[All Projects] webuipublic2020-12-16 09:13
ReportermurrdynAssigned Toarogge 
Status closedResolutionfixed 
PlatformLinuxOSRHELOS Version7
Product Version18.2.5 
Fixed in Version 
Summary0001047: Webui login returns a blank page when logging in.
DescriptionSometimes when logging into Webui or attempting to log in with a different users, I am getting a blank page. The following errors appear in the httpd error log when this occurs.

[Wed Feb 06 13:28:14.347786 2019] [:error] [pid 3627] [client x.x.x.x:63602] PHP Notice: Undefined variable: form in /usr/share/bareos-webui/module/Auth/view/auth/auth/login.phtml on line 45, referer: http://x.x.x.x/bareos-webui/auth/login
[Wed Feb 06 13:28:14.347819 2019] [:error] [pid 3627] [client x.x.x.x:63602] PHP Fatal error: Call to a member function prepare() on a non-object in /usr/share/bareos-webui/module/Auth/view/auth/auth/login.phtml on line 45, referer: http://x.x.x.x/bareos-webui/auth/login

If you refresh the blank page, I then get a page of the attached image.

Occasionally this will self heal, and the error does not appear in the logs.
Steps To ReproduceFresh install of 18.2.5 on RHEL 7.6. After first successful login into Webui with created admin account (TLS Enable = no for the console profile), error and blank page are received on next login attempt. Will self-heal within a day and then be fine until current session times out and you log back in or force the logout and back in.
Tagsbroken, webui
bareos-master: impact
bareos-master: action
bareos-19.2: impact
bareos-19.2: action
bareos-18.2: impact
bareos-18.2: action
bareos-17.2: impact
bareos-17.2: action
bareos-16.2: impact
bareos-16.2: action
bareos-15.2: impact
bareos-15.2: action
bareos-14.2: impact
bareos-14.2: action
bareos-13.2: impact
bareos-13.2: action
bareos-12.4: impact
bareos-12.4: action




2019-02-06 20:40


bareos-error.PNG (23,787 bytes)
bareos-error.PNG (23,787 bytes)


2019-02-06 20:43

reporter   ~0003251

Additional information: Created a second admin account. Can temporary work around issue switching accounts in the webui when error is encountered.


2019-02-07 02:02

reporter   ~0003252

same problem here, 18.2.5 updated from 17.2.4, system ubuntu 16.04 lts


2019-02-14 17:00

reporter   ~0003262

I originally posted this in another bug report, but I believe it applies better here:

The observation I have found, regarding this issue, is that intentionally logging out (before doing anything that triggers a session expiry response/notification) avoids triggering this bug on subsequent login.

Typically, if you remain logged in and your session expires by the time you try to perform an action, you have to log back in. This is when you encounter this bug.

Following a long idle period, if you avoid performing any action, so as to avoid being notified that your session has expired, and instead click your username and properly logout from the drop-down, you can log back in successfully without triggering this bug.

In fact, I have found that if I always deliberately logout, such that I avoid triggering the session expiry notice, I can always successfully login on the next attempt.

I have not yet tested a scenario of closing all browser windows, without logging out, then trying to login again. However, so far it seems that deliberately logging out -- even after session expiry (but without doing anything to trigger a session expiry notification) -- avoids triggering this bug.

Hope that helps with figuring out where the bug resides.


2019-07-12 11:02

developer   ~0003452

Can you please check whether deleting your cookies for the bareos-webui actually helps?


2019-12-18 15:32

developer   ~0003686

closing due to no response on feedback request


2020-02-17 14:04

reporter   ~0003819


I'm facing the exact same issue, and I can confirm that cleaning the cookies is not helping.
I tried using multiple console, admin, user1, user2 .. the "admin" (using the webui-admin) worked well, but when I started switching to a different account the problem appeared.
I thought it was because of the ACL (as the error would eventually say) but even with similar profile the bug would still appear and trying to log back to admin also fails.

redhat 7.7

Thank you


2020-02-17 14:11

developer   ~0003820

So the webui-admin worked, but the others don't?
Do you have "TLS Enable = no" in the other configurations? If not this might be the cause (and we will need a better way to detect and report that problem).


2020-03-11 00:03

reporter   ~0003895

Just a "me too".
Ubuntu 18.04
Firefox with Adblocker Ultimate installed and pi-hole.
bareos 19.2.6-2
bareos-dir Version: 19.2.6 (11 February 2020) Linux-3.10.0-1062.9.1.el7.x86_64 ubuntu Ubuntu 18.04 LTS xUbuntu_18.04 x86_6

bareos-webui directors.ini (comment lines removed for brevity):
enabled = "yes"
diraddress = "sophie"
dirport = 9101
tls_verify_peer = false
server_can_do_tls = false
server_requires_tls = false
client_can_do_tls = false
client_requires_tls = false
enabled = "no"
diraddress = ""
dirport = 9101

I haven't been in the web-ui for a couple of weeks. I haven't cleared out Firefox in months.
I just tried going into the web-ui and experienced this same error as the OP posted including in the httpd logs.
After reading this bug tracker, I cleared out only my local cookies and tried going into the web-ui again and it works, although the values for # of jobs running, waiting, successful, warn and failed all have a spinner and no values. If I tab over to Jobs then back to dashboard, they correctly display values.

I haven't tried creating multiple users.
Happy to help provide further info and try additional steps.


2020-05-30 14:35

reporter   ~0003993

Any insight into getting this fixed or working properly? Clearing the cookies only works for me some of the time and the WebUI is not working for me. I'm using Firefox under Devuan (Debian Sid) and Bareos is running on Devuan Beowulf (Debian 10). About the only thing that has worked reliable for me recently is to access the webui using a Chrome Incognito session then closing it when I'm done.


2020-12-16 09:13

developer   ~0004068

This should be fixed in the latest maintanance releases 18.2.10, 19.2.9 and in 20.0.0, too.
If it is still broken in these (or later) releases, please reopen.

Thank you!

Issue History

Date Modified Username Field Change
2019-02-06 20:40 murrdyn New Issue
2019-02-06 20:40 murrdyn Tag Attached: broken
2019-02-06 20:40 murrdyn Tag Attached: webui
2019-02-06 20:40 murrdyn File Added: bareos-error.PNG
2019-02-06 20:43 murrdyn Note Added: 0003251
2019-02-07 02:02 teka74 Note Added: 0003252
2019-02-14 17:00 xyros Note Added: 0003262
2019-07-12 11:02 arogge Status new => feedback
2019-07-12 11:02 arogge Note Added: 0003452
2019-12-18 15:32 arogge Assigned To => arogge
2019-12-18 15:32 arogge Status feedback => resolved
2019-12-18 15:32 arogge Resolution open => unable to reproduce
2019-12-18 15:32 arogge Status resolved => closed
2019-12-18 15:32 arogge Note Added: 0003686
2020-02-17 14:04 b0zzo Status closed => new
2020-02-17 14:04 b0zzo Resolution unable to reproduce => reopened
2020-02-17 14:04 b0zzo Note Added: 0003819
2020-02-17 14:11 arogge Status new => feedback
2020-02-17 14:11 arogge Note Added: 0003820
2020-03-11 00:03 Spincharm Note Added: 0003895
2020-05-30 14:35 Ryushin Note Added: 0003993
2020-12-16 09:13 arogge Status feedback => resolved
2020-12-16 09:13 arogge Resolution reopened => fixed
2020-12-16 09:13 arogge Note Added: 0004068
2020-12-16 09:13 arogge Status resolved => closed