View Issue Details

IDProjectCategoryView StatusLast Update
0000104bareos-core[All Projects] Generalpublic2015-03-25 19:19
ReportermvwieringenAssigned To 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
PlatformOpenIndianaOSOpenIndianaOS Versionb151a
Product Version13.1.0 
Fixed in Version13.1.0 
Summary0000104: Use open_bpipe wrapper in bpipe plugin.
DescriptionInstead of using popen and pclose use the Bareos wrappers open_bpipe
and close_bpipe. This way the unneeded filedescriptors are closed
on fork of the program ran under the bpipe plugin.
Additional InformationSee also

http://bugs.bacula.org/view.php?id=1987
TagsNo tags attached.
bareos-master: impact
bareos-master: action
bareos-19.2: impact
bareos-19.2: action
bareos-18.2: impact
bareos-18.2: action
bareos-17.2: impact
bareos-17.2: action
bareos-16.2: impact
bareos-16.2: action
bareos-15.2: impact
bareos-15.2: action
bareos-14.2: impact
bareos-14.2: action
bareos-13.2: impact
bareos-13.2: action
bareos-12.4: impact
bareos-12.4: action

Activities

mvwieringen adm

mvwieringen adm

2013-08-13 03:12

administrator   ~0000613

Fix committed to bareos master branch with changesetid 766.
mvwieringen

mvwieringen

2015-03-25 16:51

developer   ~0001426

Fix committed to bareos2015 bareos-13.2 branch with changesetid 4322.
joergs

joergs

2015-03-25 19:19

administrator   ~0001575

Due to the reimport of the Github repository to bugs.bareos.org, the status of some tickets have been changed. These tickets will be closed again.
Sorry for the noise.

Related Changesets

bareos-regress: master 00c17e93

2013-02-26 20:51:06

mvwieringen

Ported: N/A

Details Diff
Use open_bpipe wrapper in bpipe plugin.

Fixes 0000104: Use open_bpipe wrapper in bpipe plugin.
Affected Issues
0000104
mod - scripts/plugin-test-bareos-dir.conf.in Diff File

bareos: master 893703e8

2013-05-04 19:08:14

mvwieringen adm

Ported: N/A

Details Diff
Use open_bpipe wrapper in bpipe plugin.

Instead of using popen and pclose use the Bareos wrappers open_bpipe
and close_bpipe. This way the unneeded filedescriptors are closed
on fork of the program ran under the bpipe plugin.

Fixes 0000104: Use open_bpipe wrapper in bpipe plugin.
Affected Issues
0000104
mod - src/plugins/fd/bpipe-fd.c Diff File

bareos2015: bareos-13.2 e6c5c6fa

2013-05-04 21:08:14

mvwieringen

Ported: N/A

Details Diff
Use open_bpipe wrapper in bpipe plugin.

Instead of using popen and pclose use the Bareos wrappers open_bpipe
and close_bpipe. This way the unneeded filedescriptors are closed
on fork of the program ran under the bpipe plugin.

Fixes 0000104: Use open_bpipe wrapper in bpipe plugin.
Affected Issues
0000104
mod - src/plugins/fd/bpipe-fd.c Diff File

Issue History

Date Modified Username Field Change
2013-02-26 21:47 mvwieringen New Issue
2013-02-26 21:53 mvwieringen Changeset attached => bareos master b66f4fac
2013-02-26 21:53 mvwieringen Assigned To => mvwieringen
2013-02-26 21:53 mvwieringen Status new => closed
2013-02-26 21:53 mvwieringen Resolution open => fixed
2013-02-26 21:53 mvwieringen Changeset attached => bareos-regress master 00c17e93
2013-02-26 21:53 mvwieringen Assigned To mvwieringen =>
2013-03-04 10:16 mvwieringen Product Version 12.4.1 => 13.1.0
2013-03-04 10:16 mvwieringen Fixed in Version => 13.1.0
2013-08-13 03:12 mvwieringen adm Changeset attached => bareos master 893703e8
2013-08-13 03:12 mvwieringen adm Note Added: 0000613
2013-08-13 03:12 mvwieringen adm Assigned To => mvwieringen adm
2013-08-13 03:12 mvwieringen adm Status closed => resolved
2013-08-13 09:02 mvwieringen adm Assigned To mvwieringen adm =>
2013-08-13 09:02 mvwieringen adm Status resolved => closed
2015-03-25 16:51 mvwieringen Changeset attached => bareos2015 bareos-13.2 e6c5c6fa
2015-03-25 16:51 mvwieringen Note Added: 0001426
2015-03-25 16:51 mvwieringen Status closed => resolved
2015-03-25 19:19 joergs Note Added: 0001575
2015-03-25 19:19 joergs Status resolved => closed