View Issue Details

IDProjectCategoryView StatusLast Update
0001001bareos-core[All Projects] directorpublic2019-01-07 16:07
ReportereshkrigAssigned To 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionduplicate 
Platformx86_64OSUbuntuOS Version16.04.5
Product Version17.2.4 
Target VersionFixed in Version 
Summary0001001: Problem with the differential backup
DescriptionHi!
Sorry for my English.

I have a problem with the differential backup.

I have the following backup strategy:
full backup every 28 days
differential backup every 7 days
incremental backup every day

Here is part of the corresponding configuration:
...
Job {
    ...
    Max Full Interval = 27 days 12 hours
    Max Diff Interval = 6 days 12 hours
    ...
}
Schedule {
    ...
    Run = Level=Incremental sun-sat at 1:05
}

The result is a chain of backups:
full, incr, incr, incr, incr, incr, incr, diff, incr, incr, incr, incr, incr, incr, diff, incr and so on.

When a differential backup is performed, only files modified since last incremental backup are copied, not since previous differential backup nor full backup.

It seems to me that this is due to confusion with the variables stime and jcr->stime in the function get_level_since_time in the src/dird/job.c file.
Before the function there is a comment: "The time in jcr->stime is later passed to tell the File daemon what to do."
But operations with the variable stime do not end with the setting of the value of the variable jcr->stime when doing differential backup.

Please fix it.
Thank you very much.
TagsNo tags attached.
bareos-master: impact
bareos-master: action
bareos-18.2: impact
bareos-18.2: action
bareos-17.2: impact
bareos-17.2: action
bareos-16.2: impact
bareos-16.2: action
bareos-15.2: impact
bareos-15.2: action
bareos-14.2: impact
bareos-14.2: action
bareos-13.2: impact
bareos-13.2: action
bareos-12.4: impact
bareos-12.4: action

Relationships

duplicate of 0000951 feedbackarogge Differential backup compute date from last incremental 

Activities

eshkrig

eshkrig

2018-10-04 08:56

reporter   ~0003129

This problem violates the main function of the software: files are not backed up.
arogge

arogge

2019-01-07 16:07

developer   ~0003166

I'm closing this issue. Progress will be tracked in 0000951

Issue History

Date Modified Username Field Change
2018-08-28 10:42 eshkrig New Issue
2018-10-04 08:56 eshkrig Note Added: 0003129
2019-01-07 16:06 arogge Relationship added duplicate of 0000951
2019-01-07 16:07 arogge Note Added: 0003166
2019-01-07 16:07 arogge Status new => closed
2019-01-07 16:07 arogge Resolution open => duplicate