View Issue Details

IDProjectCategoryView StatusLast Update
0000976bareos-core[All Projects] Generalpublic2019-09-27 18:41
ReporterfrankAssigned To 
PrioritylowSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version 
Summary0000976: bconsole.py - IndexError: string index out of range in case of gui mode on
DescriptionGUI MODE ON
===========

echo -e "gui on\n.storage"|/usr/bin/bconsole.py --dirname us-dir2.bacula4.com-dir --port 9101 -p 001010100100111101010101 127.0.0.1
>>Traceback (most recent call last):
File "/usr/bin/bconsole.py", line 46, in <module>
director.interactive()
File "/usr/lib/python2.7/site-packages/bareos/bsock/lowlevel.py", line 245, in interactive
self._show_result(resultmsg)
File "/usr/lib/python2.7/site-packages/bareos/bsock/lowlevel.py", line 263, in _show_result
if msg[-2] != ord(b'\n'):
IndexError: string index out of range

GUI MODE OFF
============

echo -e ".client\n.storage"|/usr/bin/bconsole.py --dirname us-dir2.bacula4.com-dir --port 9101 -p 001010100100111101010101 127.0.0.1
>>us-dir2.ba4.com-fd
newdir_ba3-bsd-dev-fd
newdir_freebsd10.3-fd
newdir_cpe12-fd
newdir_wintest-fd
newdir_ubuntu12-fd
col_onapp-us-control1-fd
max-desctop-fd
newdir_dal01-dev-cart-sata1-fd
newdir_maxvm-fd
newdir_centos5test-fd
newdir_zimbra-fd
newdir_winplesk-fd
newdir_Imunify360-fd
TagsNo tags attached.
bareos-master: impact
bareos-master: action
bareos-18.2: impact
bareos-18.2: action
bareos-17.2: impact
bareos-17.2: action
bareos-16.2: impact
bareos-16.2: action
bareos-15.2: impact
bareos-15.2: action
bareos-14.2: impact
bareos-14.2: action
bareos-13.2: impact
bareos-13.2: action
bareos-12.4: impact
bareos-12.4: action

Activities

joergs

joergs

2019-09-27 18:41

administrator   ~0003588

I can't reproduce the problem. However, I see, that there is a check for string length already implemented. So I assume, that the problem has been foxed in between.

Issue History

Date Modified Username Field Change
2018-06-29 12:11 frank New Issue
2018-06-29 12:12 frank Assigned To => joergs
2018-06-29 12:12 frank Status new => assigned
2019-09-27 18:41 joergs Assigned To joergs =>
2019-09-27 18:41 joergs Status assigned => resolved
2019-09-27 18:41 joergs Resolution open => fixed
2019-09-27 18:41 joergs Note Added: 0003588