View Issue Details

IDProjectCategoryView StatusLast Update
0000608bareos-core[All Projects] directorpublic2019-01-16 13:19
Reporterthorsten1Assigned Toarogge 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionunable to reproduce 
PlatformLinuxOSUbuntuOS Version14.04
Product Version15.2.2 
Target VersionFixed in Version 
Summary0000608: Recycling volume not working when using directive Max Volume jobs=1
DescriptionI was confused, why Bareos did no backup since 2 days.
When I had a look at the job details I found out, that there is a problem with the Max Volume jobs=1 directive in my pool-config:

2016-01-19 02:00:13 dum01-dir JobId 740: Created new Volume "Incremental-0534" in catalog.
2016-01-19 02:00:13 Storage01 JobId 740: Labeled new Volume "Incremental-0534" on device "Storage01Device01" (/media/bareos/storage01).
2016-01-19 02:00:13 Storage01 JobId 740: Wrote label to prelabeled Volume "Incremental-0534" on device "Storage01Device01" (/media/bareos/storage01)
2016-01-19 02:00:13 dum01-dir JobId 740: Max Volume jobs=1 exceeded. Marking Volume "Incremental-0534" as Used.
2016-01-20 02:04:45 Storage01 JobId 740: Error: device.c:224 Error getting Volume info: 1998 Volume "Incremental-0264" catalog status is Used, but should be Append, Purged or Recycle.

After I changed the directive to the deprecated one (UseVolumeOnce=yes) it was working correctly.

I think there is a bug with this directive. The counter "volume jobs" won't be resetted when purging an old volume.
Steps To ReproduceConfig, which is not working:

Pool {
  Name = Incremental
  Label Format = "Incremental-"
  Storage = Storage01

  # Common Settings
  Pool Type = Backup
  Recycle = yes
  AutoPrune = yes
  Maximum Volume Jobs = 1

  # Special Settings
  Volume Retention = 15 days
  Maximum Volume Bytes = 4G
  Maximum Volumes = 100
}

Config, which is working:
Pool {
  Name = Incremental
  Label Format = "Incremental-"
  Storage = Storage01

  # Common Settings
  Pool Type = Backup
  Recycle = yes
  AutoPrune = yes
  UseVolumeOnce = yes
  Maximum Volume Jobs = 10

  # Special Settings
  Volume Retention = 15 days
  Maximum Volume Bytes = 4G
  Maximum Volumes = 100
}
TagsNo tags attached.
bareos-master: impact
bareos-master: action
bareos-18.2: impact
bareos-18.2: action
bareos-17.2: impact
bareos-17.2: action
bareos-16.2: impact
bareos-16.2: action
bareos-15.2: impactyes
bareos-15.2: actionwill care
bareos-14.2: impact
bareos-14.2: action
bareos-13.2: impact
bareos-13.2: action
bareos-12.4: impact
bareos-12.4: action

Activities

joergs

joergs

2016-01-26 16:44

administrator   ~0002163

Hi Thorsten,

I've tried to reproduce the problem. However, here "Maximum Volume Jobs = 1" works as expected.
From the source code, it looks as if Maximum Volume Jobs and UseVolumeOnce are treated identically.

From your log:

2016-01-19 02:00:13 dum01-dir JobId 740: Max Volume jobs=1 exceeded. Marking Volume "Incremental-0534" as Used.
2016-01-20 02:04:45 Storage01 JobId 740: Error: device.c:224 Error getting Volume info: 1998 Volume "Incremental-0264" catalog status is Used, but should be Append, Purged or Recycle.

Why is here a gap of 24 hours? What it has to do with "Incremental-0264"? Before it uses volume "Incremental-0534".
hostedpower

hostedpower

2016-10-03 08:48

reporter   ~0002372

Hi,


I seem to have the same in the backup job log atm, no idea what the cause is...
jacob

jacob

2016-12-01 10:50

reporter   ~0002455

According to strange datetimes in the log (24 hours gap) i can assume that the existing unfinished job (740) was overlapped by a new scheduled job trying to use the same volume. Could you examine your logs further regarding this assumption?
arogge

arogge

2019-01-16 13:19

developer   ~0003189

As nobody provided additional information we're unable to reproduce this issue. If you can provide more information, please feel free to reopen the issue.

Issue History

Date Modified Username Field Change
2016-01-22 16:53 thorsten1 New Issue
2016-01-25 14:44 joergs Assigned To => joergs
2016-01-25 14:44 joergs Status new => assigned
2016-01-25 14:46 joergs bareos-15.2: impact => yes
2016-01-25 14:46 joergs bareos-15.2: action => will care
2016-01-26 16:44 joergs Note Added: 0002163
2016-01-26 16:44 joergs Status assigned => feedback
2016-10-03 08:48 hostedpower Note Added: 0002372
2016-12-01 10:50 jacob Note Added: 0002455
2017-02-16 11:49 joergs Assigned To joergs =>
2019-01-16 13:19 arogge Note Added: 0003189
2019-01-16 13:19 arogge Status feedback => resolved
2019-01-16 13:19 arogge Resolution open => unable to reproduce
2019-01-16 13:19 arogge Assigned To => arogge