View Issue Details

IDProjectCategoryView StatusLast Update
0000144bareos-core[All Projects] directorpublic2019-11-20 23:46
ReporterpstorzAssigned To 
PrioritynormalSeverityfeatureReproducibilityhave not tried
Status newResolutionreopened 
PlatformLinuxOSanyOS Version3
Product Version12.4.2 
Fixed in Version 
Summary0000144: Extend cancel command to be able to cancel all running jobs
DescriptionEspecially when testing, it would be a very nice feature to be able to
cancel multiple jobs at once.

For the first step, it would be nice to be able to cancel all jobs.

Also useful would be to be able to cancel, jobs of a certain state, e.g.

cancel jobs state=waiting
TagsNo tags attached.
bareos-master: impact
bareos-master: action
bareos-19.2: impact
bareos-19.2: action
bareos-18.2: impact
bareos-18.2: action
bareos-17.2: impact
bareos-17.2: action
bareos-16.2: impact
bareos-16.2: action
bareos-15.2: impact
bareos-15.2: action
bareos-14.2: impact
bareos-14.2: action
bareos-13.2: impact
bareos-13.2: action
bareos-12.4: impact
bareos-12.4: action

Activities

mvwieringen adm

mvwieringen adm

2013-08-13 03:12

administrator   ~0000597

Fix committed to bareos master branch with changesetid 696.
mvwieringen

mvwieringen

2015-03-25 16:51

developer   ~0001419

Fix committed to bareos2015 bareos-13.2 branch with changesetid 4252.
joergs

joergs

2015-03-25 19:19

administrator   ~0001572

Due to the reimport of the Github repository to bugs.bareos.org, the status of some tickets have been changed. These tickets will be closed again.
Sorry for the noise.
bozonius

bozonius

2019-09-21 13:25

reporter   ~0003579

Sorry, but I think this bug /might/ be back. I am running 16.2.4, and I am seeing jobs with a status of "waiting" and I cannot cancel them.

This is on Ubuntu Linux 14.04 (yes, I know that is old, and I am moving on soon...), and the bareos packages come from the repository (not hand built).
bozonius

bozonius

2019-11-20 23:34

reporter   ~0003637

I am now running Bareos 18.2.5 on Devuan and the problem persists. I have a 'waiting' job that won't go away. I've tried using bconsole and the job is still in waiting state.

The only 'solution' I have found is to manually remove it in the database, but I prefer not to perform such invasive actions since they could damage the integrity of Bareos overall.

Related Changesets

bareos: master 536c96a2

2013-05-04 19:17:34

pstorz


Committer: mvwieringen adm

Ported: N/A

Details Diff
Extend cancel command to be able to cancel all running jobs

Especially when testing, it would be a very nice feature to be able to
cancel multiple jobs at once.

For the first step, it would be nice to be able to cancel all jobs.
Also useful would be to be able to cancel, jobs of a certain state, e.g.

cancel state=waiting

Fixes 0000144: Extend cancel command to be able to cancel all running jobs
Affected Issues
0000144
mod - src/dird/ua_select.c Diff File
mod - src/dird/ua_cmds.c Diff File

bareos2015: bareos-13.2 209fda49

2013-05-04 21:17:34

pstorz


Committer: mvwieringen

Ported: N/A

Details Diff
Extend cancel command to be able to cancel all running jobs

Especially when testing, it would be a very nice feature to be able to
cancel multiple jobs at once.

For the first step, it would be nice to be able to cancel all jobs.
Also useful would be to be able to cancel, jobs of a certain state, e.g.

cancel state=waiting

Fixes 0000144: Extend cancel command to be able to cancel all running jobs
Affected Issues
0000144
mod - src/dird/ua_cmds.c Diff File
mod - src/dird/ua_select.c Diff File

Issue History

Date Modified Username Field Change
2013-04-07 12:35 pstorz New Issue
2013-04-08 22:27 mvwieringen Assigned To => mvwieringen
2013-04-08 22:27 mvwieringen Status new => acknowledged
2013-04-09 20:33 mvwieringen Changeset attached => bareos master 60bfadaa
2013-04-11 15:39 mvwieringen Changeset attached => bareos master 67880feb
2013-04-11 15:39 mvwieringen Status acknowledged => closed
2013-04-11 15:39 mvwieringen Resolution open => fixed
2013-05-24 12:53 pstorz Status closed => resolved
2013-07-04 12:51 pstorz Status resolved => closed
2013-08-13 03:12 mvwieringen adm Changeset attached => bareos master 536c96a2
2013-08-13 03:12 mvwieringen adm Note Added: 0000597
2013-08-13 03:12 mvwieringen adm Assigned To mvwieringen => mvwieringen adm
2013-08-13 03:12 mvwieringen adm Status closed => resolved
2013-08-13 09:25 mvwieringen adm Assigned To mvwieringen adm =>
2013-08-13 09:25 mvwieringen adm Status resolved => closed
2015-03-25 16:51 mvwieringen Changeset attached => bareos2015 bareos-13.2 209fda49
2015-03-25 16:51 mvwieringen Note Added: 0001419
2015-03-25 16:51 mvwieringen Status closed => resolved
2015-03-25 19:19 joergs Note Added: 0001572
2015-03-25 19:19 joergs Status resolved => closed
2019-09-21 13:25 bozonius Status closed => new
2019-09-21 13:25 bozonius Resolution fixed => reopened
2019-09-21 13:25 bozonius Note Added: 0003579
2019-11-20 23:34 bozonius Note Added: 0003637