View Issue Details

IDProjectCategoryView StatusLast Update
0001348bareos-core[All Projects] storage daemonpublic2021-11-17 09:49
ReporterRobertF.Assigned Tobruno-at-bareos 
PriorityhighSeveritymajorReproducibilityhave not tried
Status resolvedResolutionfixed 
PlatformLinuxOSCentOSOS Version7
Product Version20.0.1 
Fixed in Version21.0.0 
Summary0001348: Fatal error: stored/askdir.cc:295 NULL Volume name. This shouldn't happen!!!
DescriptionI have the following problem we do daily backups on tape and yesterday this error appeared for the first time.
Before the update to version 20. 0. 1, the tape backup was running without any errors.

The error has only appeared so far. Do I have to change something in the settings or what may be?


Backup is done to a LTO-6 library with 4 tape drives.
Here is the job log that shows what is happening:
Additional Information
2021-05-04 09:02:59	bareos-dir JobId 220137: Error: Bareos bareos-dir 20.0.1 (02Mar21):
Build OS: Debian GNU/Linux 10 (buster)
JobId: 220137
Job: daily-DbBck-ELVMCDB57.2021-05-04_09.00.00_19
Backup Level: Full
Client: "elbct3" 20.0.1 (02Mar21) Debian GNU/Linux 10 (buster),debian
FileSet: "DbBck-ELVMCDB57" 2020-02-25 08:25:00
Pool: "DailyDbShare" (From Job resource)
Catalog: "MyCatalog" (From Client resource)
Storage: "elbct3-msl4048" (From Pool resource)
Scheduled time: 04-May-2021 09:00:00
Start time: 04-May-2021 09:00:02
End time: 04-May-2021 09:02:59
Elapsed time: 2 mins 57 secs
Priority: 10
FD Files Written: 7
SD Files Written: 7
FD Bytes Written: 28,688,204,350 (28.68 GB)
SD Bytes Written: 28,688,205,321 (28.68 GB)
Rate: 162080.3 KB/s
Software Compression: None
VSS: no
Encryption: no
Accurate: yes
Volume name(s): 1000062
Volume Session Id: 441
Volume Session Time: 1619188643
Last Volume Bytes: 2,327,573,436,416 (2.327 TB)
Non-fatal FD errors: 0
SD Errors: 1
FD termination status: OK
SD termination status: Fatal Error
Bareos binary info: official Bareos subscription
Job triggered by: Scheduler
Termination: *** Backup Error ***

2021-05-04 09:02:59	elbct3-sd JobId 220137: Elapsed time=00:02:57, Transfer rate=162.0 M Bytes/second
2021-05-04 09:02:59	elbct3-sd JobId 220137: Fatal error: stored/askdir.cc:295 NULL Volume name. This shouldn't happen!!!
2021-05-04 09:02:56	elbct3-sd JobId 220137: Releasing device "Drive3" (/dev/tape/by-id/scsi-35001438016033618-nst).
2021-05-04 09:00:00	elbct3-sd JobId 220137: Connected File Daemon at 192.168.219.133:9102, encryption: None
2021-05-04 09:00:02	elbct3-fd JobId 220137: ACL support is enabled
2021-05-04 09:00:02	elbct3-fd JobId 220137: Extended attribute support is enabled
2021-05-04 09:00:00	bareos-dir JobId 220137: FD compression disabled for this Job because AllowCompress=No in Storage resource.
2021-05-04 09:00:00	bareos-dir JobId 220137: Encryption: None
2021-05-04 09:00:00	bareos-dir JobId 220137: Handshake: Cleartext
2021-05-04 09:00:00	bareos-dir JobId 220137: Connected Client: elbct3 at 192.168.219.133:9102, encryption: None
2021-05-04 09:00:00	bareos-dir JobId 220137: Using Device "Drive3" to write.
2021-05-04 09:00:00	bareos-dir JobId 220137: Connected Storage daemon at 192.168.219.133:9103, encryption: None
2021-05-04 09:00:00	bareos-dir JobId 220137: Start Backup JobId 220137, Job=daily-DbBck-ELVMCDB57.2021-05-04_09.00.00_19
TagsNo tags attached.
bareos-master: impactyes
bareos-master: actionfixed
bareos-19.2: impact
bareos-19.2: action
bareos-18.2: impact
bareos-18.2: action
bareos-17.2: impact
bareos-17.2: action
bareos-16.2: impact
bareos-16.2: action
bareos-15.2: impact
bareos-15.2: action
bareos-14.2: impact
bareos-14.2: action
bareos-13.2: impact
bareos-13.2: action
bareos-12.4: impact
bareos-12.4: action

Activities

bruno-at-bareos

bruno-at-bareos

2021-11-17 09:48

developer   ~0004342

The root cause has been found and a PR has been merged.
https://github.com/bareos/bareos/pull/975

This will appear as fix in next 21, and for our customer under subscription in 20.0.4

Issue History

Date Modified Username Field Change
2021-05-07 08:50 RobertF. New Issue
2021-11-17 09:37 bruno-at-bareos Assigned To => bruno-at-bareos
2021-11-17 09:37 bruno-at-bareos Status new => assigned
2021-11-17 09:48 bruno-at-bareos Note Added: 0004342
2021-11-17 09:49 bruno-at-bareos Status assigned => resolved
2021-11-17 09:49 bruno-at-bareos Resolution open => fixed
2021-11-17 09:49 bruno-at-bareos Fixed in Version => 21.0.0
2021-11-17 09:49 bruno-at-bareos bareos-master: impact => yes
2021-11-17 09:49 bruno-at-bareos bareos-master: action => fixed