View Issue Details

IDProjectCategoryView StatusLast Update
0001246bareos-core[All Projects] Generalpublic2020-05-29 15:22
ReporterpstorzAssigned Topstorz 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformLinuxOSanyOS Version3
Product Version19.2.8 
Fixed in Version 
Summary0001246: oVirt plugin fails to restore to local disk with KeyError
Descriptionpython-fd-ovirt-plugin-test-fd JobId 2: Fatal error: python-fd: Traceback (most recent call last):
  File "BareosFdWrapper.py", line 66, in create_file
    return bareos_fd_plugin_object.create_file(context, restorepkt)
  File "BareosFdPluginOvirt.py", line 268, in create_file
    context, restorepkt.ofname
  File "BareosFdPluginOvirt.py", line 1521, in get_ovf_disk_alias_by_basename
    return self.ovf_disks_by_alias_and_fileref[relname]["disk-alias"]
KeyError: ('testvm1_thin_cow-3b0d105b-0803-4964-be21-ede95153761c/524941fd-ef79-494f-9831-1d49cff9ed76',)
Steps To ReproduceRun the oVirt plugin system test
TagsNo tags attached.
bareos-master: impact
bareos-master: action
bareos-19.2: impact
bareos-19.2: action
bareos-18.2: impact
bareos-18.2: action
bareos-17.2: impact
bareos-17.2: action
bareos-16.2: impact
bareos-16.2: action
bareos-15.2: impact
bareos-15.2: action
bareos-14.2: impact
bareos-14.2: action
bareos-13.2: impact
bareos-13.2: action
bareos-12.4: impact
bareos-12.4: action

Activities

pstorz

pstorz

2020-05-29 15:22

administrator   ~0003992

Fix committed to bareos bareos-19.2 branch with changesetid 13442.

Related Changesets

bareos: master a6adff11

2020-05-28 15:36:00

pstorz

Ported: N/A

Details Diff
oVirt plugin: fix restore problem to local disk

Fix local restore problem introduced with commit 112020886099.

During local restore, the restore is cancelled with a KeyError:

File "BareosFdWrapper.py", line 66, in create_file
return bareos_fd_plugin_object.create_file(context, restorepkt)
File "BareosFdPluginOvirt.py", line 268, in create_file
context, restorepkt.ofname
File "BareosFdPluginOvirt.py", line 1521, in get_ovf_disk_alias_by_basename
return self.ovf_disks_by_alias_and_fileref[relname]["disk-alias"]
KeyError: ('testvm1_thin_cow-3b0d105b-0803-4964-be21-ede95153761c/524941fd-ef79-494f-9831-1d49cff9ed76',)

The cause is that the disk alias filtering uses information that is not
fetched from the oVirt Server during local install, as it is not
contacted at all.

During local install, no disks are filtered and every disk backed up will be
restored.

Fixes 0001246: oVirt plugin fails to restore to local disk with KeyError
Affected Issues
0001246
mod - core/src/plugins/filed/BareosFdPluginOvirt.py Diff File
mod - docs/manuals/source/TasksAndConcepts/Plugins.rst Diff File

bareos: bareos-19.2 ae2ba303

2020-05-28 15:36:00

pstorz

Ported: N/A

Details Diff
oVirt plugin: fix restore problem to local disk

Fix local restore problem introduced with commit 112020886099.

During local restore, the restore is cancelled with a KeyError:

File "BareosFdWrapper.py", line 66, in create_file
return bareos_fd_plugin_object.create_file(context, restorepkt)
File "BareosFdPluginOvirt.py", line 268, in create_file
context, restorepkt.ofname
File "BareosFdPluginOvirt.py", line 1521, in get_ovf_disk_alias_by_basename
return self.ovf_disks_by_alias_and_fileref[relname]["disk-alias"]
KeyError: ('testvm1_thin_cow-3b0d105b-0803-4964-be21-ede95153761c/524941fd-ef79-494f-9831-1d49cff9ed76',)

The cause is that the disk alias filtering uses information that is not
fetched from the oVirt Server during local install, as it is not
contacted at all.

During local install, no disks are filtered and every disk backed up will be
restored.

Fixes 0001246: oVirt plugin fails to restore to local disk with KeyError
Affected Issues
0001246
mod - core/src/plugins/filed/BareosFdPluginOvirt.py Diff File
mod - docs/manuals/source/TasksAndConcepts/Plugins.rst Diff File

Issue History

Date Modified Username Field Change
2020-05-28 17:49 pstorz New Issue
2020-05-28 17:49 pstorz Status new => assigned
2020-05-28 17:49 pstorz Assigned To => pstorz
2020-05-29 15:22 pstorz Changeset attached => bareos master a6adff11
2020-05-29 15:22 pstorz Changeset attached => bareos bareos-19.2 ae2ba303
2020-05-29 15:22 pstorz Note Added: 0003992
2020-05-29 15:22 pstorz Status assigned => resolved
2020-05-29 15:22 pstorz Resolution open => fixed