View Issue Details

IDProjectCategoryView StatusLast Update
0001099bareos-core[All Projects] Generalpublic2019-09-19 10:42
ReporterScorpionking83Assigned Toarogge 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionno change required 
PlatformLinuxOSRHELOS Version7
Product Version16.2.4 
Fixed in Version 
Summary0001099: Error when opening in the web-ui volumes tab.
DescriptionSince last week Bereos 16.2.4 reports the following error:
ERROR in output_formatter.c:822 Failed to send result as json. Maybe result message to long?

I have tried to search for a solution with meta search engines, but no result.
Also this bug tracker gives no solution.

Can someone help me?
Steps To ReproduceSo I go to bareos web-ui --> storage --> and when clicking on tab 'volumes' I receive a json error containing a reference to rule 68 of an .php file. looking in the file, the rule stipulate: maximum stack depth exceeded.

Where is can I find the settings for increasing maximum stack depth?
Then we will receive a e-mail with the following error:ERROR in output_formatter.c:822 Failed to send result as json. Maybe result message to long?.

Differential / Incremental tapes are not full yet.
TagsNo tags attached.
bareos-master: impact
bareos-master: action
bareos-19.2: impact
bareos-19.2: action
bareos-18.2: impact
bareos-18.2: action
bareos-17.2: impact
bareos-17.2: action
bareos-16.2: impact
bareos-16.2: action
bareos-15.2: impact
bareos-15.2: action
bareos-14.2: impact
bareos-14.2: action
bareos-13.2: impact
bareos-13.2: action
bareos-12.4: impact
bareos-12.4: action

Relationships

has duplicate 0001098 closedarogge Foutmelding bij openen van volume tabblad 

Activities

arogge

arogge

2019-07-12 08:59

developer   ~0003446

16.2.4 is ancient.
Can you please check (maybe on a dedicated test-system with a copy of your catalog database) whether the problem still exists with the latest nightly build from https://download.bareos.org/experimental/nightly/
Thank you!
Scorpionking83

Scorpionking83

2019-07-18 17:17

reporter   ~0003497

Dear arogge,

Bareos updating process from 16.2.4 to 18.2 according the following steps, does not work:

When updating to a Bareos version containing the Subdirectories Configuration, the existing configuration will not be touched and is still the default configuration.
{ Please note! Problems can occur if you have implemented an own wildcard mechanism to load
your configuration from the same subdirectories as used by the new packages ($CONFIGDIR/
$COMPONENT. d/ */ *. conf ). In this case, newly installed configuration resource files can alter
your current configuration by adding resources. Best create a copy of your configuration directory
before updating Bareos and modify your existing configuration file to use that other directory.
ˆ As long as the old configuration file ($CONFIGDIR/$COMPONENT.conf) exists, it will be used.
ˆ The correct way of migrating to the new configuration scheme would be to split the configuration file
into resources, store them in the resource directories and then remove the original configuration file.
{ For migrating the Bareos Director configuration, the script bareos-migrate-config.sh exists. Being
called, it connects via bconsole to a running Bareos Director and creates subdirectories with the
resource configuration files.
# prepare temporary directory
mkdir /tmp/baroes-dir.d
cd /tmp/baroes-dir.d
# download migration script
wget .
,! https://raw.githubusercontent.com/bareos/bareos-contrib/master/misc/bareos-migrate-config/bareos-migrate-
# execute the script
bash bareos-migrate-config.sh
# backup old configuration
mv /etc/bareos/bareos-dir.conf /etc/bareos/bareos-dir.conf.bak
mv /etc/bareos/bareos-dir.d /etc/bareos/bareos-dir.d.bak
# make sure, that all packaged configuration resources exists,
# otherwise they will be added when updating Bareos.
for i in ‘find /etc/bareos/bareos-dir.d.bak/ -name *.conf -type f -printf "%P\n"‘; do touch .
,! "$i"; done
# install newly generated configuration
cp -a /tmp/bareos-dir.d /etc/bareos/
Commands 8.1: bareos-migrate-config.sh
Restart the Bareos Director and verify your configuration. Also make sure, that all resource configuration files coming from Bareos packages exists, in doubt as empty files, see remove configuration
resource files.
{ Another way, without splitting the configuration into resource files is:
*
mkdir $CONFIGDIR/$COMPONENT.d/migrate && mv $CONFIGDIR/$COMPONENT.conf .
,! $CONFIGDIR/$COMPONENT.d/migrate
Commands 8.2: move configuration to subdirectory
* Resources defined in both, the new configuration directory scheme and the old configuration
file, must be removed from one of the places, best from the old configuration file, after verifying
that the settings are identical with the new settings

Also the url: https://download.bareos.org/experimental/nightly/ does not work.

And how about updating 18.2 to higher future versions, what is the command to doe so?
arogge

arogge

2019-07-19 14:52

developer   ~0003500

What is it that "does not work"?
And yes, there is a "/bareos" missing in the URL. Sorry for that.
Scorpionking83

Scorpionking83

2019-07-19 23:41

reporter   ~0003507

you can close this, I will figure it out on my own.
It's too complicated to tell where the problem maybe lies, because we have only one production server and no fallout server.
But it hangs when I ran the migration script. So I had to rollback to a previous snapshot to get de production server up and running.
Logs files give not concrete cause of the issue.

But thanks for your time.
arogge

arogge

2019-07-20 11:47

developer   ~0003508

Are you sure it hang?
The database-migration from 16 to 17 takes really a lot of time (and space).
Scorpionking83

Scorpionking83

2019-08-26 13:59

reporter   ~0003559

Last edited: 2019-08-26 14:00

View 2 revisions

does the upgrade/update script also downloading a new version of Bareos directly from the internet?

If that's the case, then it is not possible to upgrade because firewall restrictions.

arogge

arogge

2019-08-26 15:00

developer   ~0003560

the database migration script just does the database migration.
Scorpionking83

Scorpionking83

2019-08-28 13:07

reporter   ~0003561

Last edited: 2019-08-30 10:49

View 2 revisions

So in other words: There will be no new versions downloaded from the bareos.org server? only db migration?

And when wil bereos 19 availible? and will there be a guide to upgrade from 18.2.5 to 19?

But in any case, thanks for your time and afford.

With kind regards from,

Ben van den Bos.

Scorpionking83

Scorpionking83

2019-09-19 08:09

reporter   ~0003574

Hi Arogge,

Are you still here?
When will bereos 19 availible?

Olso I have an other problem with auto recycle? How do I restart auto recycle and where can I find logs containing bareos auto recycle error?
arogge

arogge

2019-09-19 09:33

developer   ~0003575

Bareos 19 will be available when it is done. Maybe later this year.
There is nothing to restart with autorecycling. It just happens when it is enabled and a job needs a new volume. Logging for autorecycling is then in that job's log.
Scorpionking83

Scorpionking83

2019-09-19 10:02

reporter   ~0003576

Oké thanks
You can close this ticket.

with kind regards from,
Ben

Issue History

Date Modified Username Field Change
2019-07-11 17:34 Scorpionking83 New Issue
2019-07-12 08:59 arogge Status new => feedback
2019-07-12 08:59 arogge Note Added: 0003446
2019-07-12 09:00 arogge Relationship added has duplicate 0001098
2019-07-18 17:17 Scorpionking83 Note Added: 0003497
2019-07-18 17:17 Scorpionking83 Status feedback => new
2019-07-19 14:52 arogge Status new => feedback
2019-07-19 14:52 arogge Note Added: 0003500
2019-07-19 23:41 Scorpionking83 Note Added: 0003507
2019-07-19 23:41 Scorpionking83 Status feedback => new
2019-07-20 11:47 arogge Status new => feedback
2019-07-20 11:47 arogge Note Added: 0003508
2019-08-26 13:59 Scorpionking83 Note Added: 0003559
2019-08-26 13:59 Scorpionking83 Status feedback => new
2019-08-26 14:00 Scorpionking83 Note Edited: 0003559 View Revisions
2019-08-26 15:00 arogge Note Added: 0003560
2019-08-28 13:07 Scorpionking83 Note Added: 0003561
2019-08-30 10:49 Scorpionking83 Note Edited: 0003561 View Revisions
2019-09-19 08:09 Scorpionking83 Note Added: 0003574
2019-09-19 09:33 arogge Note Added: 0003575
2019-09-19 10:02 Scorpionking83 Note Added: 0003576
2019-09-19 10:42 arogge Assigned To => arogge
2019-09-19 10:42 arogge Status new => closed
2019-09-19 10:42 arogge Resolution open => no change required