View Issue Details

IDProjectCategoryView StatusLast Update
0001031bareos-core[All Projects] file daemonpublic2019-07-15 10:11
ReporterRoyKAssigned Toarogge 
PriorityhighSeveritycrashReproducibilityalways
Status resolvedResolutionwon't fix 
PlatformUbuntuOSLinuxOS Version18.04
Product Version18.4.1 
Target VersionFixed in Version 
Summary0001031: If attempting to backup to a bareos 16 director (running debian stretch), fd segfaultsq
DescriptionAn attempt to backup Ubuntu 18.04 with bareos-fd 18.x (both release and daily) to Bareos 16 on a Debian Stretch, first results in an error establishing TLS, and after disabling TLS in the FD, this kills the FD with a SIGSEGV. I had this on one VM some time back, but thought 'oh well', but now I have another, and this one is more important.
Steps To ReproduceTry to backup ubuntu 18.04 with bareos-fd v18 to debian running bareos-dir 16. I have both dir and sd running on this machine.
Additional Information
I would guess the problem is between bareos versions and not directly related to distro version, although I really don't know. I haven't been able to create a dump/backtrace.
TagsNo tags attached.
bareos-master: impact
bareos-master: action
bareos-18.2: impact
bareos-18.2: action
bareos-17.2: impact
bareos-17.2: action
bareos-16.2: impact
bareos-16.2: action
bareos-15.2: impact
bareos-15.2: action
bareos-14.2: impact
bareos-14.2: action
bareos-13.2: impact
bareos-13.2: action
bareos-12.4: impact
bareos-12.4: action

Activities

arogge

arogge

2019-07-15 10:11

developer   ~0003467

newer Director and SD with older FD is ok, newer FD with older Director and SD is not.

Issue History

Date Modified Username Field Change
2018-12-09 22:55 RoyK New Issue
2019-07-15 10:11 arogge Assigned To => arogge
2019-07-15 10:11 arogge Status new => resolved
2019-07-15 10:11 arogge Resolution open => won't fix
2019-07-15 10:11 arogge Note Added: 0003467