bareos-webui: bareos-16.2 c8521c09

Author Committer Branch Timestamp Parent Ported
frank frank bareos-16.2 2017-08-07 12:03:55 bareos-16.2 399c35c6 Pending
Affected Issues  0000840: bareos-webui openSUSE RPM has hard require to apache2_mod-php (5 or 7)
Changeset Fix to bugreport 0000840

To allow end users to choose the MPM way of running php7 the package
should only require httpd (work also for RHEL related) and one php
engine.

It can recommend mod_php but this will not last long in the future.

Note:

SUSE's RPM supports the Recommends tag, but it was not available
upstream until very recently. As a result, packages with Recommends will
fail to build for OBS targets Fedora_18, RHEL_6 and CentOS_6, for
example. A workaround is to exclude the Recommends tag from non-SUSE
targets. Alternatively the Recommends tag could become a Requires tag so
that a recommended package (foo) gets installed in any case on systems
that do not support RPM Recommends.

Fixes 0000840: bareos-webui openSUSE RPM has hard require to apache2_mod-php (5 or 7)
mod - packaging/obs/bareos-webui.spec Diff File