Bareos Bug Tracker
Bareos Bug Tracker

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000710bareos-core[All Projects] directorpublic2016-10-14 17:152017-06-08 15:23
Reporterhostedpower 
Assigned To 
PrioritynormalSeverityminorReproducibilityalways
StatusresolvedResolutionfixed 
PlatformLinuxOSDebianOS Version8
Product Version16.2.4rc 
Target VersionFixed in Version15.2.5 
Summary0000710: Failed to set TCP_KEEPIDLE = 5184000 on socket: Invalid argument
Description2016-10-14 17:12:28 vps53320 JobId 1: Generate VSS snapshots. Driver="Win64 VSS", Drive(s)="C"
2016-10-14 17:12:28 vps53320 JobId 1: VolumeMountpoints are not processed as onefs = yes.
2016-10-14 17:12:27 bareos-sd JobId 1: Labeled new Volume "vol-cons-0001" on device "vps53320-cons" (/home/vps53320/bareos).
2016-10-14 17:12:27 bareos-sd JobId 1: Wrote label to prelabeled Volume "vol-cons-0001" on device "vps53320-cons" (/home/vps53320/bareos)
2016-10-14 17:12:27 hostedpower-dir JobId 1: Max Volume jobs=1 exceeded. Marking Volume "vol-cons-0001" as Used.
2016-10-14 17:12:26 hostedpower-dir JobId 1: Start Backup JobId 1, Job=backup-vps53320.2016-10-14_17.12.24_08
2016-10-14 17:12:26 hostedpower-dir JobId 1: Warning: bsock_tcp.c:359 Failed to set TCP_KEEPIDLE = 5184000 on socket: Invalid argument
2016-10-14 17:12:26 hostedpower-dir JobId 1: Created new Volume "vol-cons-0001" in catalog.
2016-10-14 17:12:26 hostedpower-dir JobId 1: Using Device "vps53320-cons" to write.
2016-10-14 17:12:26 hostedpower-dir JobId 1: Warning: bsock_tcp.c:359 Failed to set TCP_KEEPIDLE = 5184000 on socket: Invalid argument

Not sure what caused this.
TagsNo tags attached.
bareos-master: impactyes
bareos-master: actionfixed
bareos-17.2: impact
bareos-17.2: action
bareos-16.2: impactyes
bareos-16.2: actionfixed
bareos-15.2: impactyes
bareos-15.2: actionfixed
bareos-14.2: impact
bareos-14.2: action
bareos-13.2: impactno
bareos-13.2: action
bareos-12.4: impactno
bareos-12.4: action
Attached Files

- Relationships
child of 0000798assignedmaik Release bareos-15.2.5 
child of 0000698closedstephand Release bareos-16.2.4 

-  Notes
(0002402)
hostedpower (reporter)
2016-10-14 17:43

Ok I found the cause, it's by setting heartbeat!

  # Enable the Heartbeat if you experience connection losses
  # (eg. because of your router or firewall configuration).
  # Additionally the Heartbeat can be enabled in bareos-sd and bareos-fd.
  #
  Heartbeat Interval = 2m
(0002403)
joergs (administrator)
2016-10-15 00:40

You set the heartbeat to 2 months.
I just say, that the default configuration, use "1m" as example.

Well, that is already wrong, as "m" correspond to month here.

I updated the examples and set it to 1 min instead.
(0002405)
joergs (administrator)
2016-10-17 17:18

Fix committed to bareos bareos-16.2 branch with changesetid 6723.
(0002654)
joergs (administrator)
2017-06-08 15:23

Fix committed to bareos bareos-15.2 branch with changesetid 7027.

- Related Changesets
bareos: bareos-16.2 8fa9d289
Timestamp: 2016-10-14 22:24:18
Author: joergs
Ported: N/A
Details ] Diff ]
fixes HeartbeatInterval example

The example has been
"Heartbeat Interval = 1m"
however, this would be 1 month.
Replaced it by "1 min".

Fixes 0000710: Failed to set TCP_KEEPIDLE ...
mod - src/defaultconfigs/bareos-dir.d/director/bareos-dir.conf.in Diff ] File ]
mod - src/defaultconfigs/d2d2t-builtin-changer/bareos-dir.conf.in Diff ] File ]
mod - src/defaultconfigs/d2d2t-disk-changer/bareos-dir.conf.in Diff ] File ]
mod - src/defaultconfigs/diskonly/bareos-dir.conf.in Diff ] File ]
bareos: bareos-15.2 6f7bac0c
Timestamp: 2016-10-14 22:24:18
Author: joergs
Ported: N/A
Details ] Diff ]
fixes HeartbeatInterval example

The example has been
"Heartbeat Interval = 1m"
however, this would be 1 month.
Replaced it by "1 min".

Fixes 0000710: Failed to set TCP_KEEPIDLE ...
mod - src/defaultconfigs/diskonly/bareos-dir.conf.in Diff ] File ]

- Issue History
Date Modified Username Field Change
2016-10-14 17:15 hostedpower New Issue
2016-10-14 17:43 hostedpower Note Added: 0002402
2016-10-15 00:40 joergs Note Added: 0002403
2016-10-15 00:40 joergs Assigned To => joergs
2016-10-15 00:40 joergs Status new => assigned
2016-10-15 00:41 joergs bareos-master: impact => yes
2016-10-15 00:41 joergs bareos-master: action => will care
2016-10-15 00:41 joergs bareos-16.2: impact => yes
2016-10-15 00:41 joergs bareos-16.2: action => will care
2016-10-15 00:41 joergs bareos-15.2: impact => yes
2016-10-15 00:41 joergs bareos-15.2: action => will care
2016-10-15 00:41 joergs bareos-13.2: impact => no
2016-10-15 00:41 joergs bareos-12.4: impact => no
2016-10-17 17:18 joergs Changeset attached => bareos bareos-16.2 8fa9d289
2016-10-17 17:18 joergs Note Added: 0002405
2016-10-17 17:18 joergs Status assigned => resolved
2016-10-17 17:18 joergs Resolution open => fixed
2017-06-08 13:19 joergs Relationship added child of 0000798
2017-06-08 13:27 joergs Relationship added child of 0000698
2017-06-08 13:27 joergs bareos-master: action will care => fixed
2017-06-08 13:27 joergs bareos-16.2: action will care => fixed
2017-06-08 13:27 joergs bareos-15.2: action will care => fixed
2017-06-08 13:27 joergs Status resolved => closed
2017-06-08 13:27 joergs Fixed in Version => 15.2.5
2017-06-08 13:27 joergs Assigned To joergs =>
2017-06-08 13:27 joergs Status closed => new
2017-06-08 13:28 joergs Status new => closed
2017-06-08 15:23 joergs Changeset attached => bareos bareos-15.2 6f7bac0c
2017-06-08 15:23 joergs Note Added: 0002654
2017-06-08 15:23 joergs Status closed => resolved


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker