Bareos Bug Tracker
Bareos Bug Tracker

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000376bareos-core[All Projects] installer / packagespublic2014-12-17 14:082015-03-25 19:19
Reporterschoenberg 
Assigned To 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformLinuxOSUbuntuOS Version12.10
Product Version14.2.2 
Target VersionFixed in Version14.2.2 
Summary0000376: dkpg error messages
DescriptionHello,

I'm new here.

I installed baroes from repositrory from ubuntu 14.04 with mysql.
(apt-get install bare bareos-database-mysql).
Last week an apt-get upgrade tried to install some updates from your repository.
But during the update there are some error messages:

bareos-database-common (14.2.2-41.2) wird eingerichtet ...
(config) dbc_go() bareos-database-common configure 2003.
dbc_config() bareos-database-common configure 2003.
dbc_set_dbtype_defaults() .
dbc_register_debconf() .
dbc_read_package_config() .
dbc_preseed_package_debconf() .
dbc_detect_supported_dbtype() mysql.
dbc_detect_installed_dbtype() mysql.
_dbc_detect_installed_dbtype() mysql.
dbc_config() bareos-database-common configure 2003.
dbc_set_dbtype_defaults() mysql.
dbc_get_app_pass() .
dbconfig-common: writing config to /etc/dbconfig-common/bareos-database-common.conf
dbconfig-common: flushing administrative password
FAILED to set Catalog MyCatalog dbdriver = mysql (/etc/bareos/bareos-dir.conf)
dpkg: Fehler beim Bearbeiten des Paketes bareos-database-common (--configure):
 Unterprozess installiertes post-installation-Skript gab den Fehlerwert 1 zurück
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von bareos-database-mysql:
 bareos-database-mysql hängt ab von bareos-database-common (= 14.2.2-41.2); aber:
  Paket baredpkg: Fehler beim Bearbeiten des Paketes bareos-database-mysql (--configure):
 Abhängigkeitsprobleme - verbleibt unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von bareos-database-tools:
 bareos-database-tools hängt ab von bareos-database-postgresql (= 14.2.2-41.2) | bareos-database-mysql (= 14.2.2-41.2) | bareos-database-sqlite3 (= 14.2.2-41.2); aber:
  Paket bareos-database-postgresql ist nicht installiert.
  Paket bareos-database-mysql ist noch nicht konfiguriert.
  Paket bareos-database-sqlite3 ist nicht installiert.
 bareos-database-tools hängt ab von bareos-database-common; aber:
  Paket bareos-database-common ist noch nicht konfiguriert.

dpkg: Fehler beim Bearbeiten des Paketes bareos-database-tools (--configure):
 Abhängigkeitsprobleme - verbleibt unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von bareos-director:
 bareos-director hängt ab von bareos-database-postgresql (= 14.2.2-41.2) | bareos-database-mysql (= 14.2.2-41.2) | bareos-database-sqlite3 (= 14.2.2-41.2); aber:
  Paket bareos-database-postgresql ist nicht installiert.
  Paket bareos-database-mysql ist noch nicht konfiguriert.
  Paket bareos-database-sqlite3 ist nicht installiert.
 bareos-director hängt ab von bareos-database-tools; aber:
  Paket bareos-database-tools ist noch nicht konfiguriert.
 bareos-director hängt ab von bareos-database-common; aber:
  Paket bareos-database-common ist noch nicht konfiguriert.

dpkg: Fehler beim Bearbeiten des Paketes bareos-director (--configure):
 Abhängigkeitsprobleme - verbleibt unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von bareos:
bareos-database-common ist noch nicht konfiguriert.
bareos hängt ab von bareos-director (= 14.2.2-41.2); aber:
  Paket bareos-director ist noch nicht konfiguriert.

dpkg: Fehler beim Bearbeiten des Paketes bareos (--configure):
 Abhängigkeitsprobleme - verbleibt unkonfiguriert
Fehler traten auf beim Bearbeiten von:
 bareos-database-common
 bareos-database-mysql
 bareos-database-tools
 bareos-director
 bareos
E: Sub-process /usr/bin/dpkg returned an error code (1)

Is this a bug, or have I to install dependency like bareos-database-postresql?

Kind regards
Uli
TagsNo tags attached.
bareos-master: impact
bareos-master: action
bareos-18.2: impact
bareos-18.2: action
bareos-17.2: impact
bareos-17.2: action
bareos-16.2: impact
bareos-16.2: action
bareos-15.2: impact
bareos-15.2: action
bareos-14.2: impact
bareos-14.2: action
bareos-13.2: impact
bareos-13.2: action
bareos-12.4: impact
bareos-12.4: action
Attached Files

- Relationships

-  Notes
(0001115)
joergs (administrator)
2014-12-17 15:01

This is a bug. When migrating from Bareos < 14.2 to Bareos >= 14.2 on Debian/Ubuntu, the package try extract information about the database backend and use this as base for dbcommon-config for configuring the database.

This have failed in your environment.

Could you please attach the Catalog section from your /etc/bareos/bareos-dir.conf file?
I seams, that it does not look the way this script expected it.
(0001116)
schoenberg (reporter)
2014-12-17 15:25

I think this is correct section:

Catalog {
  Name = MyCatalog
  # Uncomment the following lines if you want the dbi driver
  # dbdriver = "dbi:postgresql"; dbaddress = 127.0.0.1; dbport =
  #dbdriver = "postgresql"
  dbdriver = "mysql"
  dbname = "bareos"
  dbuser = "user"
  dbpassword = "PASSWORD"
}

But i put this in an own file under /etc/bareos/conf.d/catalog.conf

here is the entry from bareos-dir.conf:
# Definition des Kalaogs
@/etc/bareos/conf.d/catalog.conf
(0001117)
joergs (administrator)
2014-12-17 15:40

okay, I see. This is of course a valid configuration, however the package postinstall script did not expect this.
I'll change we code (don't fail, if the script does not find the relevant config items).
(0001127)
joergs (administrator)
2014-12-17 23:11

Fix committed to bareos master branch with changesetid 2578.
(0001130)
schoenberg (reporter)
2014-12-18 07:44

Thx for this fix, but it don't work. After an apt-get update && apt-get upgrade it the same messages.

I change my catalog config. I put my catalog settings in bareos-dir.conf, after that the update works.

Than you for you help.
(0001132)
joergs (administrator)
2014-12-18 10:15

The Fix message has been generated automatically as I commited the fix to the master branch. However, it has not yet been applied to Bareos-14.2, nor has a new version of Bareos-14.2 been published. This will happen in the next days. I'm confident, that this fix will solve the problem then.
Good that you already found a workaround.
(0001133)
joergs (administrator)
2014-12-18 15:02

Fix committed to bareos bareos-14.2 branch with changesetid 2580.
(0001141)
joergs (administrator)
2014-12-19 17:34

Problem should be fixed in bareos >= 14.2.2-44.1, which is now published.
(0001452)
mvwieringen (developer)
2015-03-25 16:51

Fix committed to bareos2015 bareos-14.2 branch with changesetid 4495.
(0001602)
joergs (administrator)
2015-03-25 19:19

Due to the reimport of the Github repository to bugs.bareos.org, the status of some tickets have been changed. These tickets will be closed again.
Sorry for the noise.

- Related Changesets
bareos: master 6c5b428c
Timestamp: 2014-12-17 18:14:16
Author: joergs
Ported: N/A
Details ] Diff ]
Debian: fixes a problem when migrating to dbconfig

in some cases, Bareos fails to apply dbconfig setting to the Bareos configuration file.
With this change, these failures only result in a warning,
instead of letting the package installation fail.

Fixes 0000376: dkpg error
mod - debian/bareos-database-common.postinst.in Diff ] File ]
mod - scripts/bareos-config-lib.sh.in Diff ] File ]
bareos: bareos-14.2 0f3c49ce
Timestamp: 2014-12-17 18:14:16
Author: joergs
Ported: N/A
Details ] Diff ]
Debian: fixes a problem when migrating to dbconfig

in some cases, Bareos fails to apply dbconfig setting to the Bareos configuration file.
With this change, these failures only result in a warning,
instead of letting the package installation fail.

Fixes 0000376: dkpg error
mod - debian/bareos-database-common.postinst.in Diff ] File ]
mod - scripts/bareos-config-lib.sh.in Diff ] File ]
bareos2015: bareos-14.2 f87d636d
Timestamp: 2014-12-17 19:14:16
Author: joergs
Committer: mvwieringen
Ported: N/A
Details ] Diff ]
Debian: fixes a problem when migrating to dbconfig

in some cases, Bareos fails to apply dbconfig setting to the Bareos configuration file.
With this change, these failures only result in a warning,
instead of letting the package installation fail.

Fixes 0000376: dkpg error
mod - debian/bareos-database-common.postinst.in Diff ] File ]
mod - scripts/bareos-config-lib.sh.in Diff ] File ]

- Issue History
Date Modified Username Field Change
2014-12-17 14:08 schoenberg New Issue
2014-12-17 14:22 joergs Assigned To => joergs
2014-12-17 14:22 joergs Status new => assigned
2014-12-17 15:01 joergs Note Added: 0001115
2014-12-17 15:03 joergs Status assigned => feedback
2014-12-17 15:25 schoenberg Note Added: 0001116
2014-12-17 15:25 schoenberg Status feedback => assigned
2014-12-17 15:40 joergs Note Added: 0001117
2014-12-17 23:11 joergs Changeset attached => bareos master 6c5b428c
2014-12-17 23:11 joergs Note Added: 0001127
2014-12-17 23:11 joergs Status assigned => resolved
2014-12-17 23:11 joergs Resolution open => fixed
2014-12-18 07:44 schoenberg Note Added: 0001130
2014-12-18 07:44 schoenberg Status resolved => feedback
2014-12-18 07:44 schoenberg Resolution fixed => reopened
2014-12-18 10:15 joergs Note Added: 0001132
2014-12-18 14:31 mvwieringen Relationship added related to 0000345
2014-12-18 14:31 mvwieringen Relationship deleted related to 0000345
2014-12-18 15:02 joergs Changeset attached => bareos bareos-14.2 0f3c49ce
2014-12-18 15:02 joergs Note Added: 0001133
2014-12-18 15:02 joergs Status feedback => resolved
2014-12-19 17:34 joergs Note Added: 0001141
2014-12-19 17:34 joergs Status resolved => closed
2014-12-19 17:34 joergs Assigned To joergs =>
2014-12-19 17:34 joergs Resolution reopened => fixed
2014-12-19 17:34 joergs Fixed in Version => 14.2.2
2015-03-25 16:51 mvwieringen Changeset attached => bareos2015 bareos-14.2 f87d636d
2015-03-25 16:51 mvwieringen Note Added: 0001452
2015-03-25 16:51 mvwieringen Status closed => resolved
2015-03-25 19:19 joergs Note Added: 0001602
2015-03-25 19:19 joergs Status resolved => closed


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker