Bareos Bug Tracker
Bareos Bug Tracker

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000294bareos-core[All Projects] Generalpublic2014-05-09 20:462015-03-25 19:18
ReporterSvenS 
Assigned To 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version12.4.6 
Target Version12.4.7Fixed in Version12.4.7 
Summary0000294: Error in bconsole-ACL
DescriptionWhen in Console-Config the StorageACL, ScheduleACL for one Client defined, then shows the 'status sd' and 'status sched'-command in bconsole on client ALL devices and all schedules from all other clients.
The same for the command 'status all'.
TagsNo tags attached.
bareos-master: impact
bareos-master: action
bareos-18.2: impact
bareos-18.2: action
bareos-17.2: impact
bareos-17.2: action
bareos-16.2: impact
bareos-16.2: action
bareos-15.2: impact
bareos-15.2: action
bareos-14.2: impact
bareos-14.2: action
bareos-13.2: impact
bareos-13.2: action
bareos-12.4: impact
bareos-12.4: action
Attached Files

- Relationships

-  Notes
(0000853)
mvwieringen (developer)
2014-05-10 09:21
edited on: 2014-05-10 13:53

The problem with the schedule acl is indeed a missed option. The other problem
is a known Bacula problem for years and can only be solved via a feature request
to change the status exchange protocol between DIR and SD e.g. add the wanted
storage in the protocol when you now ask for a certain storage you always get
all storage on a certain SD. Problem also is that the storage definition on the
DIR could map to something different on the SD e.g. autochanger vs different drives etc. so it needs quite some form of redesign.
Probably also one of the reasons why it never happened in the past as this problem has been first acknowledged year ago.

(0000855)
mvwieringen (developer)
2014-05-11 22:46

Fix committed to bareos bareos-13.2 branch with changesetid 1754.
(0000856)
mvwieringen (developer)
2014-05-11 22:47

Fix committed to bareos bareos-12.4 branch with changesetid 1757.
(0001350)
mvwieringen (developer)
2015-03-25 16:51

Fix committed to bareos2015 bareos-13.2 branch with changesetid 4018.
(0001506)
joergs (administrator)
2015-03-25 19:18

Due to the reimport of the Github repository to bugs.bareos.org, the status of some tickets have been changed. These tickets will be closed again.
Sorry for the noise.

- Related Changesets
bareos: master fa247360
Timestamp: 2014-05-10 18:45:41
Author: mvwieringen
Ported: N/A
Details ] Diff ]
Don't show unauthorized schedules/jobs in status scheduler.

Fixes 0000290: Error in bconsole-ACL
mod - src/dird/ua_status.c Diff ] File ]
bareos: bareos-13.2 fe1cb60d
Timestamp: 2014-05-10 18:45:41
Author: mvwieringen
Ported: N/A
Details ] Diff ]
Don't show unauthorized schedules/jobs in status scheduler.

Fixes 0000294: Error in bconsole-ACL
mod - src/dird/ua_status.c Diff ] File ]
bareos: bareos-12.4 e96e45e6
Timestamp: 2014-05-10 18:45:41
Author: mvwieringen
Ported: N/A
Details ] Diff ]
Don't show unauthorized schedules/jobs in status scheduler.

Fixes 0000294: Error in bconsole-ACL
mod - src/dird/ua_status.c Diff ] File ]
bareos2015: bareos-12.4 fac7dacc
Timestamp: 2014-05-10 20:45:41
Author: mvwieringen
Ported: N/A
Details ] Diff ]
Don't show unauthorized schedules/jobs in status scheduler.

Fixes 0000294: Error in bconsole-ACL
mod - src/dird/ua_status.c Diff ] File ]
bareos2015: bareos-13.2 3008f0c9
Timestamp: 2014-05-10 20:45:41
Author: mvwieringen
Ported: N/A
Details ] Diff ]
Don't show unauthorized schedules/jobs in status scheduler.

Fixes 0000294: Error in bconsole-ACL
mod - src/dird/ua_status.c Diff ] File ]

- Issue History
Date Modified Username Field Change
2014-05-09 20:46 SvenS New Issue
2014-05-10 09:21 mvwieringen Note Added: 0000853
2014-05-10 09:21 mvwieringen Status new => confirmed
2014-05-10 09:21 mvwieringen Target Version => 13.2.3
2014-05-10 13:53 mvwieringen Note Edited: 0000853 View Revisions
2014-05-10 20:57 mvwieringen Changeset attached => bareos master fa247360
2014-05-11 22:46 mvwieringen Changeset attached => bareos bareos-13.2 fe1cb60d
2014-05-11 22:46 mvwieringen Note Added: 0000855
2014-05-11 22:46 mvwieringen Assigned To => mvwieringen
2014-05-11 22:46 mvwieringen Status confirmed => resolved
2014-05-11 22:46 mvwieringen Resolution open => fixed
2014-05-11 22:47 mvwieringen Changeset attached => bareos bareos-12.4 e96e45e6
2014-05-11 22:47 mvwieringen Note Added: 0000856
2014-05-16 16:58 mvwieringen adm Assigned To mvwieringen =>
2014-05-16 16:58 mvwieringen adm Status resolved => closed
2014-05-16 17:00 mvwieringen adm Product Version 13.2.2 => 12.4.6
2014-05-16 17:00 mvwieringen adm Fixed in Version => 12.4.7
2014-05-16 17:00 mvwieringen adm Target Version 13.2.3 => 12.4.7
2015-03-25 16:51 mvwieringen Changeset attached => bareos2015 bareos-12.4 fac7dacc
2015-03-25 16:51 mvwieringen Changeset attached => bareos2015 bareos-13.2 3008f0c9
2015-03-25 16:51 mvwieringen Note Added: 0001350
2015-03-25 16:51 mvwieringen Status closed => resolved
2015-03-25 19:18 joergs Note Added: 0001506
2015-03-25 19:18 joergs Status resolved => closed


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker