Bareos Bug Tracker
Bareos Bug Tracker

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000261bareos-core[All Projects] directorpublic2013-12-12 15:422015-03-25 19:19
Reporterdenny 
Assigned Topstorz 
PrioritynormalSeveritycrashReproducibilitysometimes
StatusclosedResolutionfixed 
PlatformAMD64OSDebianOS Version7
Product Version13.2.2 
Target Version13.2.3Fixed in Version13.2.3 
Summary0000261: "cancel all" crashs often director
DescriptionI use often "cancel all" to cancel all jobs, because of misconfiguration or testing the setup. If I do so, the director crashes very often, after accepting the selected jobs. I can see, how the first 0000003:0000005 jobs are marked as canceled, than I'm back on the normal Linux console and the director is down:

syslog:

Dec 12 12:19:41 BACKUP bareos-dir: BAREOS interrupted by signal 11: Segmentation violation
Dec 12 13:48:27 BACKUP bareos-dir: BAREOS interrupted by signal 11: Segmentation violation
Dec 12 13:59:49 BACKUP bareos-dir: BAREOS interrupted by signal 11: Segmentation violation
Dec 12 14:01:20 BACKUP bareos-dir: BAREOS interrupted by signal 11: Segmentation violation
Steps To Reproduce1. start for example a copy job with a log of jobs
2. type "cancel all"
3. accept "y"
Additional InformationIt isn't reproducible at any time, but it happens often. Maybe the parser has a problem ... I had to cancel round about 25 jobs.
TagsNo tags attached.
bareos-master: impact
bareos-master: action
bareos-18.2: impact
bareos-18.2: action
bareos-17.2: impact
bareos-17.2: action
bareos-16.2: impact
bareos-16.2: action
bareos-15.2: impact
bareos-15.2: action
bareos-14.2: impact
bareos-14.2: action
bareos-13.2: impact
bareos-13.2: action
bareos-12.4: impact
bareos-12.4: action
Attached Files

- Relationships
has duplicate 0000287closed Director crashes when limiting bandwidth for running job 

-  Notes
(0000766)
pstorz (administrator)
2013-12-19 13:13

Fix committed to bareos bareos-13.2 branch with changesetid 1387.
(0000767)
pstorz (administrator)
2013-12-19 13:13

Fix committed to bareos master branch with changesetid 1390.
(0001414)
mvwieringen (developer)
2015-03-25 16:51

Fix committed to bareos2015 bareos-13.2 branch with changesetid 4089.
(0001566)
joergs (administrator)
2015-03-25 19:19

Due to the reimport of the Github repository to bugs.bareos.org, the status of some tickets have been changed. These tickets will be closed again.
Sorry for the noise.

- Related Changesets
bareos: bareos-13.2 84439d8c
Timestamp: 2013-12-18 11:34:03
Author: pstorz
Ported: N/A
Details ] Diff ]
Fixed wrong handling of cancel command

Fixes 0000261: cancel all" crashs often director
mod - src/dird/ua_select.c Diff ] File ]
bareos: master 2dd77631
Timestamp: 2013-12-18 11:34:03
Author: pstorz
Ported: N/A
Details ] Diff ]
Fixed wrong handling of cancel command

Fixes 0000261: cancel all" crashs often director
mod - src/dird/ua_select.c Diff ] File ]
bareos2015: bareos-13.2 a46d8e9a
Timestamp: 2013-12-18 12:34:03
Author: pstorz
Committer: mvwieringen
Ported: N/A
Details ] Diff ]
Fixed wrong handling of cancel command

Fixes 0000261: cancel all" crashs often director
mod - src/dird/ua_select.c Diff ] File ]

- Issue History
Date Modified Username Field Change
2013-12-12 15:42 denny New Issue
2013-12-19 13:13 pstorz Changeset attached => bareos bareos-13.2 84439d8c
2013-12-19 13:13 pstorz Note Added: 0000766
2013-12-19 13:13 pstorz Assigned To => pstorz
2013-12-19 13:13 pstorz Status new => resolved
2013-12-19 13:13 pstorz Resolution open => fixed
2013-12-19 13:13 pstorz Changeset attached => bareos master 2dd77631
2013-12-19 13:13 pstorz Note Added: 0000767
2014-03-26 10:47 pstorz Relationship added has duplicate 0000287
2014-05-16 17:02 mvwieringen adm Status resolved => closed
2014-05-16 17:02 mvwieringen adm Fixed in Version => 13.2.3
2014-05-16 17:02 mvwieringen adm Target Version => 13.2.3
2015-03-25 16:51 mvwieringen Changeset attached => bareos2015 bareos-13.2 a46d8e9a
2015-03-25 16:51 mvwieringen Note Added: 0001414
2015-03-25 16:51 mvwieringen Status closed => resolved
2015-03-25 19:19 joergs Note Added: 0001566
2015-03-25 19:19 joergs Status resolved => closed


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker