Bareos Bug Tracker
Bareos Bug Tracker

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000260bareos-core[All Projects] Generalpublic2013-12-11 17:392015-03-25 19:18
Reportertuxmaster 
Assigned To 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformSolaris10OSSolarisOS Version10
Product Version13.2.2 
Target Version13.2.3Fixed in Version13.2.3 
Summary0000260: Unable to compile/install the client under Solaris 10 U11
DescriptionTwo error have I found:
First at the build stage.
Here means the compiler that an conversion from void* to char* is illegal. (see fix below)
Second at the install step:
gmake install will fail because in the Makefile "platforms/Makefile" "Make" is set to make and not gmake.
Steps To Reproduceas an normal user:
PATH=$PATH:/usr/sfw/bin (needed, without it configure don't find the compiler)
./configure --enable-client-only --disable-build-stored
--disable-build-dird --without-pyhton --prefix=/opt/bareos
gmake
fails see description
patch the file
gmake (works)
gmake install (as root)
fails
patch platforms/Makefile
gmake install (works)
Additional InformationSolution:
modify file src/lib/bsys.c line 889:
ret_buffer[i] = actuallymalloc(len = strlen(linebuffer) + 1);
by
ret_buffer[i] = (char*)actuallymalloc(len = strlen(linebuffer) + 1);
TagsNo tags attached.
bareos-master: impact
bareos-master: action
bareos-18.2: impact
bareos-18.2: action
bareos-17.2: impact
bareos-17.2: action
bareos-16.2: impact
bareos-16.2: action
bareos-15.2: impact
bareos-15.2: action
bareos-14.2: impact
bareos-14.2: action
bareos-13.2: impact
bareos-13.2: action
bareos-12.4: impact
bareos-12.4: action
Attached Files

- Relationships

-  Notes
(0000759)
mvwieringen (developer)
2013-12-12 11:22

Fix committed to bareos bareos-13.2 branch with changesetid 1375.
(0000760)
mvwieringen (developer)
2013-12-12 11:22

Fix committed to bareos bareos-12.4 branch with changesetid 1376.
(0000761)
mvwieringen (developer)
2013-12-12 11:22

Fix committed to bareos master branch with changesetid 1374.
(0001354)
mvwieringen (developer)
2015-03-25 16:51

Fix committed to bareos2015 bareos-14.2 branch with changesetid 4962.
(0001508)
joergs (administrator)
2015-03-25 19:18

Due to the reimport of the Github repository to bugs.bareos.org, the status of some tickets have been changed. These tickets will be closed again.
Sorry for the noise.

- Related Changesets
bareos: master f38ef0b5
Timestamp: 2013-12-12 10:11:27
Author: mvwieringen
Ported: N/A
Details ] Diff ]
Fix Solaris 10 build.

Fixes 0000260: Unable to compile/install the client under Solaris 10 U11
mod - platforms/Makefile.in Diff ] File ]
mod - src/lib/bsys.c Diff ] File ]
bareos: bareos-13.2 2a515d93
Timestamp: 2013-12-12 10:11:27
Author: mvwieringen
Ported: N/A
Details ] Diff ]
Fix Solaris 10 build.

Fixes 0000260: Unable to compile/install the client under Solaris 10 U11
mod - platforms/Makefile.in Diff ] File ]
mod - src/lib/bsys.c Diff ] File ]
bareos: bareos-12.4 10e79f4e
Timestamp: 2013-12-12 10:11:27
Author: mvwieringen
Ported: N/A
Details ] Diff ]
Fix Solaris 10 build.

Fixes 0000260: Unable to compile/install the client under Solaris 10 U11
mod - platforms/Makefile.in Diff ] File ]
mod - src/lib/bsys.c Diff ] File ]
bareos2015: bareos-12.4 67c6471a
Timestamp: 2013-12-12 11:11:27
Author: mvwieringen
Ported: N/A
Details ] Diff ]
Fix Solaris 10 build.

Fixes 0000260: Unable to compile/install the client under Solaris 10 U11
mod - platforms/Makefile.in Diff ] File ]
mod - src/lib/bsys.c Diff ] File ]
bareos2015: bareos-13.2 0169d434
Timestamp: 2013-12-12 11:11:27
Author: mvwieringen
Ported: N/A
Details ] Diff ]
Fix Solaris 10 build.

Fixes 0000260: Unable to compile/install the client under Solaris 10 U11
mod - platforms/Makefile.in Diff ] File ]
mod - src/lib/bsys.c Diff ] File ]
bareos2015: bareos-14.2 94d20e15
Timestamp: 2013-12-12 11:11:27
Author: mvwieringen
Ported: N/A
Details ] Diff ]
Fix Solaris 10 build.

Fixes 0000260: Unable to compile/install the client under Solaris 10 U11
mod - platforms/Makefile.in Diff ] File ]
mod - src/lib/bsys.c Diff ] File ]

- Issue History
Date Modified Username Field Change
2013-12-11 17:39 tuxmaster New Issue
2013-12-12 11:22 mvwieringen Changeset attached => bareos bareos-13.2 2a515d93
2013-12-12 11:22 mvwieringen Note Added: 0000759
2013-12-12 11:22 mvwieringen Assigned To => mvwieringen
2013-12-12 11:22 mvwieringen Status new => resolved
2013-12-12 11:22 mvwieringen Resolution open => fixed
2013-12-12 11:22 mvwieringen Changeset attached => bareos bareos-12.4 10e79f4e
2013-12-12 11:22 mvwieringen Note Added: 0000760
2013-12-12 11:22 mvwieringen Changeset attached => bareos master f38ef0b5
2013-12-12 11:22 mvwieringen Note Added: 0000761
2014-05-16 17:26 mvwieringen adm Assigned To mvwieringen =>
2014-05-16 17:26 mvwieringen adm Status resolved => closed
2014-05-16 17:26 mvwieringen adm Fixed in Version => 13.2.3
2014-05-16 17:26 mvwieringen adm Target Version => 13.2.3
2015-03-25 16:51 mvwieringen Changeset attached => bareos2015 bareos-12.4 67c6471a
2015-03-25 16:51 mvwieringen Changeset attached => bareos2015 bareos-13.2 0169d434
2015-03-25 16:51 mvwieringen Changeset attached => bareos2015 bareos-14.2 94d20e15
2015-03-25 16:51 mvwieringen Note Added: 0001354
2015-03-25 16:51 mvwieringen Status closed => resolved
2015-03-25 19:18 joergs Note Added: 0001508
2015-03-25 19:18 joergs Status resolved => closed


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker