Bareos Bug Tracker
Bareos Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000166bareos-core[All Projects] storage daemonpublic2013-04-30 16:592013-06-06 16:14
Reporteruser12 
Assigned Touser12 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformLinuxOSRHELOS Version6
Product Version12.4.3 
Target Version12.4.4Fixed in Version12.4.4 
Summary0000166: bareos-sd seems not to shutdown properly - drive lock prevents media removal
Descriptionshutdown fails using command "service bareos-sd stop".

It is a storage daemon with a cristie tapelibrary fibrechannel LTO-5 24 slots, 2 drives

At the moment of shutdown, each drive was loaded with a tape cartridge and two backups were sucessfull done.

After the command, bareos-sd seems still up. But it seems, it takes a little longer to rewind the tape and unlock the drive. The timewait or whatever of the /etc/init.d/bareos-sd script wrong?

And it doesn't seem to unlock the drive properly, because the tapelibrary states "drive media removal prevented by host 45"

After unplugging from fc-switch and rebooting the tapelibrary, the drive was unlocked und one could remove the tapes from the drive
Steps To Reproduce[root@rhel-6 ~]# service bareos-sd stop
Stopping Bareos Storage services: [ FEHLGESCHLAGEN ]
Additional InformationI'll be friday at customers site and will provide the output of bareos-sd -d 300 or should I go higher with the debug-level?
TagsNo tags attached.
bareos-master: impact
bareos-master: action
bareos-18.2: impact
bareos-18.2: action
bareos-17.2: impact
bareos-17.2: action
bareos-16.2: impact
bareos-16.2: action
bareos-15.2: impact
bareos-15.2: action
bareos-14.2: impact
bareos-14.2: action
bareos-13.2: impact
bareos-13.2: action
bareos-12.4: impact
bareos-12.4: action
Attached Files

- Relationships

-  Notes
(0000383)
mvwieringen (developer)
2013-04-30 19:47

Try using the new option

NoRewindOnClose = Yes

which should not try to rewind the drive (which makes no sense anyway
as on start the tape is rewinded anyway.)

Regarding the locking of the drive I expect it to be cleared successfully
if it doesn't try to rewind the drive.
(0000391)
user12
2013-05-06 16:14

Tried new option, seems to work
(0000417)
mvwieringen (developer)
2013-05-10 17:08

NoRewindOnClose is from now on the default.
(0000445)
user12
2013-06-06 16:14

No complains since then.

- Issue History
Date Modified Username Field Change
2013-04-30 16:59 user12 New Issue
2013-04-30 19:44 mvwieringen Assigned To => mvwieringen
2013-04-30 19:44 mvwieringen Status new => assigned
2013-04-30 19:47 mvwieringen Note Added: 0000383
2013-04-30 19:47 mvwieringen Status assigned => feedback
2013-05-06 16:14 user12 Note Added: 0000391
2013-05-06 16:14 user12 Status feedback => assigned
2013-05-10 17:06 mvwieringen Changeset attached => bareos master 6092d098
2013-05-10 17:06 mvwieringen Changeset attached => bareos Branch-12.4 ba05cf0d
2013-05-10 17:08 mvwieringen Note Added: 0000417
2013-05-10 17:08 mvwieringen Assigned To mvwieringen =>
2013-05-10 17:08 mvwieringen Status assigned => resolved
2013-05-10 17:08 mvwieringen Resolution open => fixed
2013-05-10 17:08 mvwieringen Fixed in Version => 12.4.4
2013-05-10 17:08 mvwieringen Target Version => 12.4.4
2013-06-06 16:14 user12 Note Added: 0000445
2013-06-06 16:14 user12 Status resolved => closed
2013-06-06 16:14 user12 Assigned To => user12


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker