Bareos Bug Tracker
Bareos Bug Tracker

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000160bareos-core[All Projects] directorpublic2013-04-19 16:142015-03-25 19:18
Reporteruser12 
Assigned To 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformLinuxOSUbuntuOS Version12.04
Product Version12.4.2 
Target Version12.4.4Fixed in Version12.4.4 
Summary0000160: Job overwrite "nextpool" in run command in bconsole doesn't work
DescriptionThe job overwrite works perfectly in the schedule resource, but not in bconsole, when doing manual backup
Steps To Reproducebconsole:

*run job=2ndCopy2Tape
Run Copy job
JobName: 2ndCopy2Tape
Bootstrap: *None*
Client: sl-bareos01-fd
FileSet: StdLinux
Pool: VFB (From Job resource)
NextPool: Tape_8d (From unknown source)
Read Storage: VFB (From Pool resource)
Write Storage: TSL (From Storage from Run NextPool override)
JobId: *None*
When: 2013-03-25 14:34:45
Catalog: MyCatalog
Priority: 13
OK to run? (yes/mod/no): no


*run job=2ndCopy2Tape nextpool=Tape_2y
Run Copy job
JobName: 2ndCopy2Tape
Bootstrap: *None*
Client: sl-bareos01-fd
FileSet: StdLinux
Pool: VFB (From Job resource)
NextPool: Tape_2y (From command line)
Read Storage: VFB (From Pool resource)
Write Storage: TSL (From Storage from Run NextPool override)
JobId: *None*
When: 2013-03-25 14:34:54
Catalog: MyCatalog
Priority: 13

*mess
*[...]
  Current Job: 2ndCopy2Tape.2013-03-25_14.32.52_40
  Backup Level: Full
  Client: sl-bareos01-fd
  FileSet: "StdLinux" 2013-05-22 22:05:30
  Read Pool: "VFB" (From Job resource)
  Read Storage: "VFB" (From Pool resource)
  Write Pool: "Tape_8d" (From Job Pool's NextPool resource)
  Write Storage: "TSL" (From Storage from Pool's NextPool resource)
  Next Pool: "Tape_8d" (From Job Pool's NextPool resource)
[...]


Additional InformationSchedule {
  Name = "2ndCopy2Tape"
  Run = Full nextpool=Tape_2y Priority=13 2nd mon at 22:00
}

Pool {
  Name = VFB
  Label Format = "VFB-"
  Pool Type = Backup
  Recycle = yes # Bareos can automatically recycle Volumes
  AutoPrune = yes # Prune expired volumes
  Volume Retention = 3 month # one year
  Volume Use Duration = 12 hours
  Storage = VFB
  Next Pool = Tape_8d
}

Pool {
  Name = Tape_8d
  Pool Type = Backup
  Recycle = yes
  AutoPrune = yes
  Volume Retention = 20 days
  Volume Use Duration = 12 hours
  Storage = TSL
}

Pool {
  Name = Tape_2y
  Pool Type = Backup
  Recycle = yes
  AutoPrune = yes
  Volume Retention = 2 years
  Volume Use Duration = 24 hours
  Storage = TSL
}
TagsNo tags attached.
bareos-master: impact
bareos-master: action
bareos-18.2: impact
bareos-18.2: action
bareos-17.2: impact
bareos-17.2: action
bareos-16.2: impact
bareos-16.2: action
bareos-15.2: impact
bareos-15.2: action
bareos-14.2: impact
bareos-14.2: action
bareos-13.2: impact
bareos-13.2: action
bareos-12.4: impact
bareos-12.4: action
Attached Files

- Relationships

-  Notes
(0000366)
mvwieringen (developer)
2013-04-22 11:19

capture the output from a bareos-dir -f -d 200 then we can take it from there.
(0000446)
user12
2013-06-06 16:22

works with Version 12.4.3-657.1
(0000591)
mvwieringen adm (administrator)
2013-08-13 03:12

Fix committed to bareos bareos-12.4 branch with changesetid 944.
(0001377)
mvwieringen (developer)
2015-03-25 16:51

Fix committed to bareos2015 bareos-13.2 branch with changesetid 4234.
(0001531)
joergs (administrator)
2015-03-25 19:18

Due to the reimport of the Github repository to bugs.bareos.org, the status of some tickets have been changed. These tickets will be closed again.
Sorry for the noise.

- Related Changesets
bareos: bareos-12.4 a797f6cb
Timestamp: 2013-05-04 11:15:04
Author: mvwieringen adm
Ported: N/A
Details ] Diff ]
Try to fix nextpool overide via runcmd.

Fixes 0000160: Job overwrite "nextpool" in run command in bconsole doesn't work
mod - src/dird/ua_run.c Diff ] File ]
bareos2015: bareos-12.4 c25eee25
Timestamp: 2013-05-04 13:15:04
Author: mvwieringen
Ported: N/A
Details ] Diff ]
Try to fix nextpool overide via runcmd.

Fixes 0000160: Job overwrite "nextpool" in run command in bconsole doesn't work
mod - src/dird/ua_run.c Diff ] File ]
bareos: master 699a0f06
Timestamp: 2013-05-04 19:25:20
Author: mvwieringen adm
Ported: N/A
Details ] Diff ]
Try to fix nextpool overide via runcmd.

Fixes 0000160: Job overwrite "nextpool" in run command in bconsole doesn't work
mod - src/dird/ua_run.c Diff ] File ]
bareos2015: bareos-13.2 55042d35
Timestamp: 2013-05-04 21:25:20
Author: mvwieringen
Ported: N/A
Details ] Diff ]
Try to fix nextpool overide via runcmd.

Fixes 0000160: Job overwrite "nextpool" in run command in bconsole doesn't work
mod - src/dird/ua_run.c Diff ] File ]

- Issue History
Date Modified Username Field Change
2013-04-19 16:14 user12 New Issue
2013-04-22 11:19 mvwieringen Note Added: 0000366
2013-04-22 11:19 mvwieringen Assigned To => mvwieringen
2013-04-22 11:19 mvwieringen Status new => feedback
2013-04-22 11:21 mvwieringen Target Version => 12.4.4
2013-04-23 17:39 mvwieringen Changeset attached => bareos Branch-12.4 81a7e16c
2013-04-23 17:39 mvwieringen Note Added: 0000374
2013-04-23 17:39 mvwieringen Status feedback => closed
2013-04-23 17:39 mvwieringen Resolution open => fixed
2013-04-23 17:39 mvwieringen Changeset attached => bareos master 06edfe57
2013-04-23 17:39 mvwieringen Note Added: 0000375
2013-04-23 17:40 mvwieringen Assigned To mvwieringen =>
2013-04-23 17:40 mvwieringen Status closed => resolved
2013-04-23 17:40 mvwieringen Fixed in Version => 12.4.4
2013-06-06 16:22 user12 Note Added: 0000446
2013-06-06 16:22 user12 Status resolved => closed
2013-06-06 16:22 user12 Assigned To => user12
2013-08-13 03:12 mvwieringen adm Changeset attached => bareos master 699a0f06
2013-08-13 03:12 mvwieringen adm Changeset attached => bareos bareos-12.4 a797f6cb
2013-08-13 03:12 mvwieringen adm Note Added: 0000591
2013-08-13 03:12 mvwieringen adm Assigned To user12 => mvwieringen adm
2013-08-13 03:12 mvwieringen adm Status closed => resolved
2013-08-13 09:30 mvwieringen adm Note Deleted: 0000374
2013-08-13 09:30 mvwieringen adm Note Deleted: 0000375
2013-08-13 09:31 mvwieringen adm Assigned To mvwieringen adm =>
2013-08-13 09:31 mvwieringen adm Status resolved => closed
2015-03-25 16:51 mvwieringen Changeset attached => bareos2015 bareos-12.4 c25eee25
2015-03-25 16:51 mvwieringen Changeset attached => bareos2015 bareos-13.2 55042d35
2015-03-25 16:51 mvwieringen Note Added: 0001377
2015-03-25 16:51 mvwieringen Status closed => resolved
2015-03-25 19:18 joergs Note Added: 0001531
2015-03-25 19:18 joergs Status resolved => closed


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker