Bareos Bug Tracker
Bareos Bug Tracker

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000159bareos-core[All Projects] Generalpublic2013-04-19 09:322015-03-25 19:18
Reporterdaniel 
Assigned To 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformLinuxOSOS Version
Product Version12.4.3 
Target Version12.4.4Fixed in Version12.4.4 
Summary0000159: Display Error in bconsole for status slots; did not show empty slot after load
DescriptionIf you load a tape into the loader, the empty slot shows a the same entries like the tape informations of slot 1 instead of the common question mark for empty slots.
Steps To ReproduceLoad any tape greater than Slot 1 into drive slot 0. There is no difference if you perfom the load with mtx or bconsole. The display error occure with both methods.
Additional Information*status slots
The defined Storage resources are:
     1: FileStorage
     2: TandbergT40
Select Storage resource (1-2): 2
Automatically selected Catalog: MyCatalog
Using Catalog "MyCatalog"
Connecting to Storage daemon TandbergT40 at bacula:9103 ...
3306 Issuing autochanger "slots" command.
Device "Drive-1" has 39 slots.
Connecting to Storage daemon TandbergT40 at bacula:9103 ...
3301 Issuing autochanger "loaded? drive 0" command.
3302 Autochanger "loaded? drive 0", result is Slot 8.
3306 Issuing autochanger "listall" command.
 Slot | Volume Name | Status | Media Type | Pool |
------+------------------+-----------+----------------+--------------------------|
    1 | A00036L4 | Append | LTO4 | Export-VMImage-Pool |
    2 | A00017L4 | Full | LTO4 | LTO4Pool |
    3 | A00032L4 | Append | LTO4 | VMImage-Pool |
    4 | A00023L4 | Recycle | LTO4 | Export-Server-Pool |
    5 | A00029L4 | Purged | LTO4 | Scratch |
    6 | A00033L4 | Purged | LTO4 | Scratch |
    7 | A00037L4 | Purged | LTO4 | Scratch |
    8*| A00036L4 | Append | LTO4 | Export-VMImage-Pool |
    9 | A00039L4 | Full | LTO4 | LTO4Pool |
   10 | A00015L4 | Full | LTO4 | VMImage-Pool |
   11 | A00031L4 | Purged | LTO4 | Scratch |
   12 | A00022L4 | Recycle | LTO4 | Export-Server-Pool |
   13 | A00014L4 | Purged | LTO4 | Scratch |
TagsNo tags attached.
bareos-master: impact
bareos-master: action
bareos-18.2: impact
bareos-18.2: action
bareos-17.2: impact
bareos-17.2: action
bareos-16.2: impact
bareos-16.2: action
bareos-15.2: impact
bareos-15.2: action
bareos-14.2: impact
bareos-14.2: action
bareos-13.2: impact
bareos-13.2: action
bareos-12.4: impact
bareos-12.4: action
Attached Files

- Relationships

-  Notes
(0000364)
mvwieringen (developer)
2013-04-22 11:13

Its a typo in the code which leads to always moving one item to far in
the linked list. Fix is commited but will be linked to this bug report
when the source integration problems are fixed.
(0000390)
daniel (administrator)
2013-05-06 14:38

I ve tested the fix on SLES and openSuSe. And its fit to the descriped result. So Bug is fixed
(0000594)
mvwieringen adm (administrator)
2013-08-13 03:12

Fix committed to bareos bareos-12.4 branch with changesetid 946.
(0001380)
mvwieringen (developer)
2015-03-25 16:51

Fix committed to bareos2015 bareos-13.2 branch with changesetid 4237.
(0001532)
joergs (administrator)
2015-03-25 19:18

Due to the reimport of the Github repository to bugs.bareos.org, the status of some tickets have been changed. These tickets will be closed again.
Sorry for the noise.

- Related Changesets
bareos: bareos-12.4 e407353f
Timestamp: 2013-05-04 11:15:03
Author: mvwieringen adm
Ported: N/A
Details ] Diff ]
Show right info in status slots.

Slot should not be empty but show the correct loaded volume info and
not the first slot after the drive in the enumeration.

Fixes 0000159: Display Error in bconsole for status slots; did not show empty slot after load
mod - src/dird/ua_status.c Diff ] File ]
bareos2015: bareos-12.4 01409808
Timestamp: 2013-05-04 13:15:03
Author: mvwieringen
Ported: N/A
Details ] Diff ]
Show right info in status slots.

Slot should not be empty but show the correct loaded volume info and
not the first slot after the drive in the enumeration.

Fixes 0000159: Display Error in bconsole for status slots; did not show empty slot after load
mod - src/dird/ua_status.c Diff ] File ]
bareos: master 5aee9372
Timestamp: 2013-05-04 19:25:11
Author: mvwieringen adm
Ported: N/A
Details ] Diff ]
Show right info in status slots.

Slot should not be empty but show the correct loaded volume info and
not the first slot after the drive in the enumeration.

Fixes 0000159: Display Error in bconsole for status slots; did not show empty slot after load
mod - src/dird/ua_status.c Diff ] File ]
bareos2015: bareos-13.2 d167d22b
Timestamp: 2013-05-04 21:25:11
Author: mvwieringen
Ported: N/A
Details ] Diff ]
Show right info in status slots.

Slot should not be empty but show the correct loaded volume info and
not the first slot after the drive in the enumeration.

Fixes 0000159: Display Error in bconsole for status slots; did not show empty slot after load
mod - src/dird/ua_status.c Diff ] File ]

- Issue History
Date Modified Username Field Change
2013-04-19 09:32 daniel New Issue
2013-04-22 11:13 mvwieringen Note Added: 0000364
2013-04-22 11:13 mvwieringen Assigned To => mvwieringen
2013-04-22 11:13 mvwieringen Status new => confirmed
2013-04-23 12:51 mvwieringen Changeset attached => bareos master 7c0eb99a
2013-04-23 12:51 mvwieringen Note Added: 0000368
2013-04-23 12:51 mvwieringen Status confirmed => closed
2013-04-23 12:51 mvwieringen Resolution open => fixed
2013-04-23 12:53 mvwieringen Assigned To mvwieringen =>
2013-04-23 12:53 mvwieringen Fixed in Version => 12.4.4
2013-04-23 12:53 mvwieringen Target Version 12.4.3 => 12.4.4
2013-04-23 16:29 mvwieringen Changeset attached => bareos Branch-12.4 248ddd72
2013-04-23 16:29 mvwieringen Note Added: 0000373
2013-04-23 17:41 mvwieringen Assigned To => mvwieringen
2013-04-23 17:41 mvwieringen Status closed => resolved
2013-04-24 09:50 mvwieringen Assigned To mvwieringen =>
2013-05-06 14:38 daniel Note Added: 0000390
2013-05-06 14:40 daniel Status resolved => closed
2013-08-13 03:12 mvwieringen adm Changeset attached => bareos master 5aee9372
2013-08-13 03:12 mvwieringen adm Changeset attached => bareos bareos-12.4 e407353f
2013-08-13 03:12 mvwieringen adm Note Added: 0000594
2013-08-13 03:12 mvwieringen adm Assigned To => mvwieringen adm
2013-08-13 03:12 mvwieringen adm Status closed => resolved
2013-08-13 09:21 mvwieringen adm Note Deleted: 0000368
2013-08-13 09:21 mvwieringen adm Note Deleted: 0000373
2013-08-13 09:22 mvwieringen adm Assigned To mvwieringen adm =>
2013-08-13 09:22 mvwieringen adm Status resolved => closed
2015-03-25 16:51 mvwieringen Changeset attached => bareos2015 bareos-12.4 01409808
2015-03-25 16:51 mvwieringen Changeset attached => bareos2015 bareos-13.2 d167d22b
2015-03-25 16:51 mvwieringen Note Added: 0001380
2015-03-25 16:51 mvwieringen Status closed => resolved
2015-03-25 19:18 joergs Note Added: 0001532
2015-03-25 19:18 joergs Status resolved => closed


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker