Bareos Bug Tracker
Bareos Bug Tracker

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000148bareos-core[All Projects] installer / packagespublic2013-04-11 17:012015-03-25 19:18
Reporteruser12 
Assigned To 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformLinuxOSUbuntuOS Version12.04
Product Version12.4.2 
Target Version12.4.3Fixed in Version12.4.3 
Summary0000148: Backup Error: BackupCatalog fails duescript make_catalog_backup needs binary bareos-dbcheck, which is in bareos-database-tools
DescriptionJob BackupCatalog fails. bareos-dbcheck is needed, but not found.

When installing bareos (apt-get install bareos bareos-database-postgresql) the user is not able to do backup of the bareos-catalog, because binary bareos-dbcheck (in package bareos-database-tools) is needed, but does not get installed by default

BackupCatalog script make_catalog_backup needs binary bareos-dbcheck, which is in bareos-database-tools. bareos-database-tools is not suggested or automatically installed.
Steps To Reproduceroot@sl-bareos01:~# apt-get install bareos bareos-database-postgresql
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following extra packages will be installed:
  bareos-bconsole bareos-client bareos-common bareos-database-common bareos-director bareos-filedaemon bareos-storage
  bareos-traymonitor
Suggested packages:
  bareos-doc dds2tar scsitools sg3-utils kde gnome-desktop-environment
The following NEW packages will be installed
  bareos bareos-bconsole bareos-client bareos-common bareos-database-common bareos-database-postgresql
  bareos-director bareos-filedaemon bareos-storage bareos-traymonitor
0 upgraded, 10 newly installed, 0 to remove and 3 not upgraded.
Need to get 0 B/1,377 kB of archives.
After this operation, 3,755 kB of additional disk space will be used.


root@sl-bareos01:~# bconsole
Connecting to Director sl-bareos01:9101
1000 OK: sl-bareos01-dir Version: 12.4.2 (03 March 2013)
Enter a period to cancel a command.
*
*run job=BackupCatalog
[...]
*auto on
11-Apr 16:58 sl-bareos01-dir JobId 1: shell command: run BeforeJob "/usr/lib/bareos/scripts/make_catalog_backup.pl MyCa
talog"
11-Apr 16:58 sl-bareos01-dir JobId 1: BeforeJob: sh: 1: /usr/sbin/bareos-dbcheck: not found
11-Apr 16:58 sl-bareos01-dir JobId 1: BeforeJob: Can't find your catalog (MyCatalog) in director configuration
11-Apr 16:58 sl-bareos01-dir JobId 1: Error: Runscript: BeforeJob returned non-zero status=1. ERR=Child exited with cod
e 1
11-Apr 16:58 sl-bareos01-dir JobId 1: Error: Bareos sl-bareos01-dir 12.4.2 (03Mar13):
  Build OS: x86_64-pc-linux-gnu ubuntu Ubuntu 12.04 LTS
  JobId: 1
  Job: BackupCatalog.2013-04-11_16.58.31_04
  Backup Level: Full
  Client: "sl-bareos01-fd"
  FileSet: "Catalog" 2013-04-11 16:58:31
  Pool: "B2D" (From Job resource)
  Catalog: "MyCatalog" (From Pool resource)
  Storage: "B2D" (From Pool resource)
  Scheduled time: 11-Apr-2013 16:58:28
  Start time: 11-Apr-2013 16:58:33
  End time: 11-Apr-2013 16:58:33
  Elapsed time: 0 secs
  Priority: 11
  FD Files Written: 0
  SD Files Written: 0
  FD Bytes Written: 0 (0 B)
  SD Bytes Written: 0 (0 B)
  Rate: 0.0 KB/s
  Software Compression: None
  VSS: no
  Encryption: no
  Accurate: yes
  Volume name(s):
  Volume Session Id: 0
  Volume Session Time: 0
  Last Volume Bytes: 0 (0 B)
  Non-fatal FD errors: 1
  SD Errors: 0
  FD termination status:
  SD termination status:
  Termination: *** Backup Error ***
TagsNo tags attached.
bareos-master: impact
bareos-master: action
bareos-18.2: impact
bareos-18.2: action
bareos-17.2: impact
bareos-17.2: action
bareos-16.2: impact
bareos-16.2: action
bareos-15.2: impact
bareos-15.2: action
bareos-14.2: impact
bareos-14.2: action
bareos-13.2: impact
bareos-13.2: action
bareos-12.4: impact
bareos-12.4: action
Attached Files

- Relationships

-  Notes
(0000596)
mvwieringen adm (administrator)
2013-08-13 03:12

Fix committed to bareos bareos-12.4 branch with changesetid 956.
(0001382)
mvwieringen (developer)
2015-03-25 16:51

Fix committed to bareos2015 bareos-13.2 branch with changesetid 4250.
(0001535)
joergs (administrator)
2015-03-25 19:18

Due to the reimport of the Github repository to bugs.bareos.org, the status of some tickets have been changed. These tickets will be closed again.
Sorry for the noise.

- Related Changesets
bareos: bareos-12.4 bc8dd47d
Timestamp: 2013-05-04 11:14:59
Author: joergs
Committer: mvwieringen adm
Ported: N/A
Details ] Diff ]
bareos-director requires bareos-database-tools

make_catalog_backup.pl (from bareos-director) requires bareso-dbcheck (from bareos-database-tools).

Fixes 0000148: bareos-director requires bareos-database-tools

Signed-off-by: Marco van Wieringen <marco.van.wieringen@bareos.com>
mod - debian/control Diff ] File ]
mod - platforms/rpms/bareos.spec Diff ] File ]
bareos2015: bareos-12.4 748795be
Timestamp: 2013-05-04 13:14:59
Author: joergs
Committer: mvwieringen
Ported: N/A
Details ] Diff ]
bareos-director requires bareos-database-tools

make_catalog_backup.pl (from bareos-director) requires bareso-dbcheck (from bareos-database-tools).

Fixes 0000148: bareos-director requires bareos-database-tools

Signed-off-by: Marco van Wieringen <marco.van.wieringen@bareos.com>
mod - debian/control Diff ] File ]
mod - platforms/rpms/bareos.spec Diff ] File ]
bareos: master 305026b3
Timestamp: 2013-05-04 19:18:17
Author: joergs
Committer: mvwieringen adm
Ported: N/A
Details ] Diff ]
bareos-director requires bareos-database-tools

make_catalog_backup.pl (from bareos-director) requires bareso-dbcheck (from bareos-database-tools).

Fixes 0000148: bareos-director requires bareos-database-tools

Signed-off-by: Marco van Wieringen <marco.van.wieringen@bareos.com>
mod - platforms/rpms/bareos.spec Diff ] File ]
mod - debian/control Diff ] File ]
bareos2015: bareos-13.2 8804fab9
Timestamp: 2013-05-04 21:18:17
Author: joergs
Committer: mvwieringen
Ported: N/A
Details ] Diff ]
bareos-director requires bareos-database-tools

make_catalog_backup.pl (from bareos-director) requires bareso-dbcheck (from bareos-database-tools).

Fixes 0000148: bareos-director requires bareos-database-tools

Signed-off-by: Marco van Wieringen <marco.van.wieringen@bareos.com>
mod - debian/control Diff ] File ]
mod - platforms/rpms/bareos.spec Diff ] File ]

- Issue History
Date Modified Username Field Change
2013-04-11 17:01 user12 New Issue
2013-04-11 17:07 user12 Assigned To => joergs
2013-04-11 17:07 user12 Status new => assigned
2013-04-11 18:53 mvwieringen Changeset attached => bareos master caa62453
2013-04-11 18:53 mvwieringen Note Added: 0000342
2013-04-11 18:53 mvwieringen Assigned To joergs => mvwieringen
2013-04-11 18:53 mvwieringen Status assigned => closed
2013-04-11 18:53 mvwieringen Resolution open => fixed
2013-04-11 18:53 mvwieringen Changeset attached => bareos Branch-12.4 a8af9fd1
2013-04-11 18:53 mvwieringen Note Added: 0000343
2013-04-11 18:55 mvwieringen Assigned To mvwieringen =>
2013-04-11 18:55 mvwieringen Fixed in Version => 12.4.3
2013-04-11 18:55 mvwieringen Target Version => 12.4.3
2013-08-13 03:12 mvwieringen adm Changeset attached => bareos master 305026b3
2013-08-13 03:12 mvwieringen adm Changeset attached => bareos bareos-12.4 bc8dd47d
2013-08-13 03:12 mvwieringen adm Note Added: 0000596
2013-08-13 03:12 mvwieringen adm Assigned To => mvwieringen adm
2013-08-13 03:12 mvwieringen adm Status closed => resolved
2013-08-13 09:24 mvwieringen adm Note Deleted: 0000342
2013-08-13 09:24 mvwieringen adm Note Deleted: 0000343
2013-08-13 09:24 mvwieringen adm Assigned To mvwieringen adm =>
2013-08-13 09:24 mvwieringen adm Status resolved => closed
2015-03-25 16:51 mvwieringen Changeset attached => bareos2015 bareos-12.4 748795be
2015-03-25 16:51 mvwieringen Changeset attached => bareos2015 bareos-13.2 8804fab9
2015-03-25 16:51 mvwieringen Note Added: 0001382
2015-03-25 16:51 mvwieringen Status closed => resolved
2015-03-25 19:18 joergs Note Added: 0001535
2015-03-25 19:18 joergs Status resolved => closed


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker